DVD drive and cd drive is not detected!

Status
Not open for further replies.

pranavrahul

Distinguished
Jan 5, 2006
4
0
18,510
0
Hi guys,
I have a big problem. My computer cannot detect my dvd or cd drive.
The dvd drive is of samsung and cd drive is of liteon. Its not the power supply because when i press the open button the drive opens. My computer screen appears without any DVD or cd drive icon. Do i have to install driver or something else. PLEASE HELP!!!!!!!!!!
 

vikaskajal

Distinguished
Jan 16, 2006
1
0
18,510
0
hi guys;
same problem with me.my computer wont even start with a dvd drive.cd drive is working fine.without dvd computer works normally.wat can be the problem.?it all started when i downloaded new drivers for dvd and re-started my pc
 

ADCampbell

Distinguished
Apr 4, 2006
2
0
18,510
0
Im goin through the same thing here and I am at a loss. I've checked the cable, the jumper selection..(its on cable select)....and the cable/power connections....The power is flowing to it because it opens when i press the eject button. Im now at a loss...what should I do?
 

chunkymonster

Splendid
Jan 12, 2006
3,678
0
22,960
78
have a big problem. My computer cannot detect my dvd or cd drive. The dvd drive is of samsung and cd drive is of liteon. Its not the power supply because when i press the open button the drive opens. My computer screen appears without any DVD or cd drive icon. Do i have to install driver or something else. PLEASE HELP!!!!!!!!!!
same problem with me.my computer wont even start with a dvd drive.cd drive is working fine.without dvd computer works normally.wat can be the problem.?it all started when i downloaded new drivers for dvd and re-started my pc
Im goin through the same thing here and I am at a loss. I've checked the cable, the jumper selection..(its on cable select)....and the cable/power connections....The power is flowing to it because it opens when i press the eject button. Im now at a loss...what should I do?
Make one drive the the Master and the other the Slave, don't set both to Cable Select.

Is it not recognizing the drives in the BIOS or Windows? Try changing IDE cables?

If BIOS, have you gone into the BIOS and verified that the drives are detected? Try changing the BIOS settings for the IDE Channels from AUTO to CD-ROM. At least then, from a hardware viewpoint, you are forcing the system to recognize.

If machine is not recognizing the drives after a firmware update, then quite possibly could have been a bad flash. Try re-flashing the the firmware.

Try going into Disk Management and verify that there is a drive letter assigned for the ROM.
 

Datman

Distinguished
Nov 20, 2004
875
0
18,980
0
Have you checked for Virus's, had this happen to me sometime back. My computer couldn't see the CD drives, damm virus.
 

vinnyguy22

Distinguished
Jun 27, 2007
1
0
18,510
0
I HAVE THE SOLUTION.

This happened to me and i called a dell support guy and he fixed it!!!

This is what you do...

Start the Run Command Prompt

Type in "regedit" without the parrenthesis then click ok

Go to HKEY_LOCAL_MACHINE

Then SYSTEM

Then CURRENT CONTROL SET

Then CONTROL

Then CLASS

Then find {4D36E965-E325-11CE-BFC1-08002BE10318}

The whole thing looks like this:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E965-E325-11CE-BFC1-08002BE10318}

Then delete the upper and lower filters....

RESTART YOUR COMPUTER THEN THERE YA GO!!!! HOPE THIS HELPS
 

texaken

Distinguished
Dec 24, 2007
1
0
18,510
0
none of these worked for me.go to bios.ide function set up. set channels optical drives on to mode 1. drives can then be seen in my computer
 

lconley

Distinguished
Sep 28, 2008
5
0
18,510
0


OMG THANK U! I have a Toshiba A135 laptop running Vista & never had a problem with my burner (factory installed DVD-Multi) then all of a sudden I went in to copy a movie to my computer & it wasn't showing in my shrink software so I went to My Computer & it was there either...Not in disk management, nothing, so I wasn't for sure if this would work or not since you said you called Dell support (sorry I'm a breeze at using the computer but nothing on the technical side) & mine's a Toshiba but I started my Command Prompt by the search feature & looked to see if I had the right file & I did. So I completed the steps & prayed that once I deleted those filters that I wouldn't need them again (never ever backed up & wouldn't know how to & I didn't want to loose all my files & pics of my babies) & that when it restarted it would work. First thing I did when I booted back up was to go to My Computer & OMG IT MY D: DRIVE WAS BACK!!!!. This was the only 'fix' I had tried as I was trying to look through a couple & see what I thought might work best since it was working in the first place & came with my laptop when I purchased it new.

I CANNOT THINK YOU ENOUGH!

Oh yeah, does anybody know why some USB items won't install or won't stay installed (out of 5 printers - new - they install but when I unplug the usb cable & then go back later to print something it has to go through the installation again even though I don't have to insert the disc). Some items won't even pick up like a bluetooth dongle...We've determined that it's the computer but I was too stupid to send it back while it was still under warranty...This has happened since the day we got it...Any help would be GREAT (from anybody LOL)!!!
 

lconley

Distinguished
Sep 28, 2008
5
0
18,510
0
Sorry about all the mistakes in the above message, I'm just so excited that my brain & hands just are working together LOL! THANKS AGAIN!
 

wombatski

Distinguished
Oct 9, 2008
1
0
18,510
0
I have carried out the instructions in the registry and I can now play and record CDs. The drive also recognises I have a blank DVD loaded but I cannot record anything to it! Any suggestions.
 

lconley

Distinguished
Sep 28, 2008
5
0
18,510
0


OKAY BIG PROBLEM - i followed this before (as you can see in the above posts & it worked) but now it's gone again! Any tips, do I follow the same steps or are the filters back or what? Please help!!!
 
G

Guest

Guest
What do you mean by remove the upper and lower filters? I can see the entry you mention but don't understand the removal of filters
 

lconley

Distinguished
Sep 28, 2008
5
0
18,510
0
I HAVE THE SOLUTION.

This happened to me and i called a dell support guy and he fixed it!!!
This is what you do...
Start the Run Command Prompt
Type in "regedit" without the parenthesis then click ok
Go to HKEY_LOCAL_MACHINE
Then SYSTEM
Then CURRENT CONTROL SET
Then CONTROL
Then CLASS
Then find {4D36E965-E325-11CE-BFC1-08002BE10318}
The whole thing looks like this:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E965-E325-11CE-BFC1-08002BE10318}

Then delete the upper and lower filters....

RESTART YOUR COMPUTER THEN THERE YA GO!


When you click on the {4D36E965-E325-11CE-BFC1-08002BE10318} 'folder' you'll see an 'Upper Filter' & a 'Lower Filter' - just click on them & then hit the delete key on your keyboard. I think that mine popped up asking me if I was sure I wanted to do this & I chose yes. Then just restart. It should be back without any hassle. The last time I had this happen I had to go back through the same steps & sure enough one of the filters was back, so I just deleted it again & it my drive has been back ever since!!!!

Hope this helps you like it did me! :)
 

lunales

Distinguished
Dec 27, 2008
2
0
18,510
0


i'm having the same issues and i tried your solution but mine didn't go as well as yours. also on the registry i only have an upper filter, no lower. after the restart the drive is still not back. :sweat: any more suggestions?
also it is a dell inspiron laptop.
 

lconley

Distinguished
Sep 28, 2008
5
0
18,510
0
Hmmm...Did you delete the upper filter before restart (probably a stupid question but I figured I would ask)? If so, I would try the same steps again to see if they are still there, if that doesn't work, IDK, maybe try Dell's support website to see if they have any solutions (they may offer free email support if your laptop is out of warranty or there may be forums there from other users with the same problems). Sorry I couldn't be of more help, I'm a complete idiot when it comes to hardware, I can use software pretty good but hardware is foreign to me LOL I wish you luck because I know what you are going through personally, & it's not only aggravating but kinda makes you wanna freak out LOL :hello:
 

lunales

Distinguished
Dec 27, 2008
2
0
18,510
0
Yes I deleted the upper filter and restarted. Figured I might have to do it again but there are no filters anymore. Then after a few hours I had to use the laptop again and the CD drive was there and after a few minutes it's gone again. It can be a virus but my anti-virus is up-to-date and it's not detecting any viruses or worms.
Thanks anyway. :) at least my problem is not rare.
...and I'm really freaking out! :eek:
 

marequi

Distinguished
Jan 2, 2009
1
0
18,510
0
Thank you! This worked for me as well. I followed the instructions to modify the registry and after rebooting my cd/dvd drive was recognized and now works.

Great solution!
 
G

Guest

Guest
:hello: :hello: :hello: :hello: This may help some people and may not help some people but here it goes: - :hello: :hello: :hello: :hello:

CD-ROM or DVD-ROM Drive Appears To Be Missing:

1. Click Start, and then click Run.
2. In the Open box, type regedit, and then click OK.
3. Locate and then click the following registry subkey:
HKEY_LOCAL_MACHINE/System/CurrentControlSet/Control/Class/{4d36e965-e325-11ce-bfc1-08002be10318}
4. Click the REG_MULTI_SZ data type UpperFilters, and then click Delete on the Edit menu. When you are prompted to confirm the deletion, click Yes.
5. Click the REG_MULTI_SZ data type LowerFilters, and then click Delete on the Edit menu. When you are prompted to confirm the deletion, click Yes.
6. Quit Registry Editor, and then restart the computer.


And another way is to make sure you have correctly inserted the IDE and Power Cables, this really made me laugh as I am an IT technician and even I made a fault of putting the IDE cable in the wrong way around, I stressed on how I am going to fix this as it was a new Sony DVD RW Drive that I had purchased online and the cost of having it shipped back and forth then to my amusment I decided to see if the cable would wrok the other way around and in fact that was the correct side up.

Glad I could share this with you and hope you all the best in any problems your PC’s (devils) have/ having.

Peace I’m out.
:pt1cable: :fou: :pt1cable: :sleep:
 
G

Guest

Guest
:hello: :hello: :hello: This may help some people and may not help some people but here it goes: - :hello: :hello: :hello:

CD-ROM or DVD-ROM Drive Appears To Be Missing:

1. Click Start, and then click Run.
2. In the Open box, type regedit, and then click OK.
3. Locate and then click the following registry subkey:
HKEY_LOCAL_MACHINE/System/CurrentControlSet/Control/Class/{4d36e965-e325-11ce-bfc1-08002be10318}
4. Click the REG_MULTI_SZ data type UpperFilters, and then click Delete on the Edit menu. When you are prompted to confirm the deletion, click Yes.
5. Click the REG_MULTI_SZ data type LowerFilters, and then click Delete on the Edit menu. When you are prompted to confirm the deletion, click Yes.
6. Quit Registry Editor, and then restart the computer.


And another way is to make sure you have correctly inserted the IDE and Power Cables, this really made me laugh as I am an IT technician and even I made a fault of putting the IDE cable in the wrong way around, I stressed on how I am going to fix this as it was a new Sony DVD RW Drive that I had purchased online and the cost of having it shipped back and forth then to my amusement I decided to see if the cable would work the other way round and in fact that was the correct side up.

Glad I could share this with you and hope you all the best in any problems your PC’s (devils) have/ having.

Peace I’m out.
:pt1cable: :fou: :lol: :pt1cable: :sleep:
 
G

Guest

Guest
Fantastic - I have a Dell Inspiron and removing the filters has brought back my D drive, I was just about to order a new one, thinking that the original was broken!
THANK YOU!!!!
 
G

Guest

Guest


Hey thanks a lot. Your code worked. Thanks a lots again. my drive is alive after about 4 months of being dead and useless. Now i am able to do all the activities that i am used to do with it. Can you also give me some tips regarding the usb port. My pen drive is not getting detected. Any advice please?
 

Jrady

Distinguished
Jan 23, 2009
1
0
18,510
0
Hi I've had the same problem on my Inspiron B130, and I've tried deleting the upper and lower filters, and I've tried the firmware download, and the firmware download worked, but the CD drive dissapeared again. So, the next time on the boot menu the option to boot to the CD drive was not there, but then a couple days later it was there, and then the CD drive dissapeared again and now I'm having the same problem with the boot to the CD drive not showing up on the boot menu. So, can somebody tell me why the CD drive keeps dissapearing, and how I can fix that?
 

NSK

Distinguished
Feb 4, 2009
1
0
18,510
0
Hi,

I've had the same problem (actually on several computers in the past as well), however I have no upper or lower filters showing at all?

Any further help?
 
Status
Not open for further replies.

ASK THE COMMUNITY

TRENDING THREADS