• Find an incredible deal for Black Friday or Cyber Monday? Share those epic bargains with the community by posting them in this forum thread!

DVD won't play

G

Guest

Guest
Hey guys & gals, I'm faced w/a bit of a problem. I have an ASUS 8x DVD drive which doesn't seem to want to play a DVD anymore. I've recently installed Win2000 (after other troubles), and I've tried using ASUS DVD and ASUS DVD2000 software. I can get the software to come to the screen where the FBI warning shows, but then it stops the movie and goes back to the default splash screen. The region is already set to USA/Canada. Other info is as follows.

ASUS A7v133 Mobo w/onboard audio & t-bird 800
ASUS V6600 Deluxe 32MB GeForce 256
9.1GB Quantum Fireball (c:)
4.3GB Quantum Fireball
4x2x24 Creative CDRW
AMD Family Ethernet Card

I've tried everything I can think of, from downloading the newer drivers from VIA or ASUS. Also, I've noticed that my HDD's are set up as SCSI, but they're actually IDE drives. I know I have them hooked up to the ATA66 controller on my mobo, so I don't know why they're listed as SCSI (the mobo has an onboard promise ATA100 chip w/separate ide channels). Thanks a ton in advance for any advice.
 

amdchuck

Distinguished
Feb 6, 2001
452
0
18,810
8
The Promise controller and any HD's connected to it are listed as SCSI device's but if your hard drives are not using the Promise ports but the onboard ATA66 ports as you say, they should not be listed as SCSI drives. That seems odd.

What I would do is set the DVD drive up as the master drive on the secondary ATA66 channel, do not slave any other devices off it, just try to get the DVD drive to work on it's own channel. If you have it chained with any other devices, that may be the problem.
 

ASK THE COMMUNITY