Edge problem that makes external links take forever to load

thxcobra

Prominent
Jan 30, 2018
7
0
510
0
So whenever i press a link in an external program (thats not a browser), it freezes the program, and takes about 60 seconds before opening the link and unfreezing the program.
From what I've gathered its a common problem and its some kind of error in Microsoft Edge, because Edge interferes when you press links even if Edge isn't your primary browser.

Things I've tried:
Re-installing Edge, Repairing and resetting Edge in settings, Restarting PC multiple times.

I havent been able to find a solution online so if anyone knows what exactly is causing this i would appreciate it.

My system has just gotten a fresh install of windows 10 and all files deleted. Since i did that the problem has occured.
 

androbourne

Estimable
Jul 18, 2017
2,322
0
2,960
402
Does it work fine if you set another browser as default and try opening links?

Edge has always had weird one off issues for me. I never use it anymore. I use Chrome or Firefox only.

That's pretty standard for a lot of users as well.
 

thxcobra

Prominent
Jan 30, 2018
7
0
510
0


Edge isn't my standard browser though. I use Google Chrome, but whenever you click external links, Edge still interferes even though it isn't your standard browser.

I tried setting my default browser to "Edge" but the same thing is happening. Program freezes for 60 sec, then the link opens and program unfreezes.
 

androbourne

Estimable
Jul 18, 2017
2,322
0
2,960
402
How are you setting another browser as defaults?

With Windows 10 you more often then not need to search for "default programs" and set it in there. Don't do it within the browser directly.
 

thxcobra

Prominent
Jan 30, 2018
7
0
510
0


I am doing it inside the Windows 10 "Default app" settings.
 

thxcobra

Prominent
Jan 30, 2018
7
0
510
0


I am pretty sure it sets it correctly. When i choose Google Chrome it makes the apps flash for a second as if it has just updated something. Whenever i click external links they are also opened in google chrome. If it didnt set it correctly it would have opened them in Edge.

If i reopen the settings it also still says "Default Browser: Google Chrome"
 

thxcobra

Prominent
Jan 30, 2018
7
0
510
0


Chrome has just been installed since my PC has just had a fresh install of Windows, so it should be up to date.

I doubt it will make much of a difference with Firefox since all external links still goes through Edge even though it isnt your primary browser, and it is a problem within Edge, so Firefox would produce the same results.
 

thxcobra

Prominent
Jan 30, 2018
7
0
510
0


Same result. Do you know anything about this issue or are you just giving out the normal generic solutions people give to any PC problem? I've already said where the problem lies, so changing to different browers wont work, i knew that.
Once again the issue is in Edge, since Edge always interferes with external links even though it isnt your primary browser. Its a common problem if you search google, but havent found a solution yet.
 

androbourne

Estimable
Jul 18, 2017
2,322
0
2,960
402
Its called troubleshooting. There is not just one fix for every issue and since we are not sitting in front of your PC. We have to do it this way.

Sometimes these issues are so simple yet people skip over the basic solutions because they "dont believe that will fix it". 90% of the times, that is exactly what fixes.

If I were you I wouldn't be asking such questing those giving you FREE tech support. Especially when I'm the only one actually trying to assist you.

If you are not willing to go through troubleshooting steps. I'll let someone else deal with this.
 

Similar threads


TRENDING THREADS