Electrical Charge on Chassis

centurion79b

Distinguished
Feb 24, 2009
3
0
18,510
I am building my first computer and after assembling the parts I have noticed that the chassis has a mild electrical charge (2 to 3 Volts) whenever I hook up either the power cord or even just a monitor cord.

Obviously I have a short somewhere on the chassis but I would appreciate hearing from anyone who has had this problem before with regards as to how to find the short.

I'm am very reluctant to power up the computer.

I have the following parts:

1. ASUS P6T MOBO
2. Corsair TX750W PSU
3. Nvidia GTX295 Graphics Card

If anyone can offer some suggestions on how to find the short and fix it I would greatl welcome the advise.
 

atomiktoaster

Distinguished
Dec 28, 2007
41
0
18,530
I've never had that problem before, but the only way I could see that happening would through the back of the motherboard, or some fault in the PSU.

Did you install the motherboard standoffs in the case before you screwed in the motherboard, and all they all in the correct positions? That's the first question that comes to mind.

How did you measure the voltage? With a voltmeter between the case and the ground wire? Consider removing the power supply from the case and checking the supply itself out. Also, check the resistance on each wire in the power cord. A little more info on your method would be helpful.
 

centurion79b

Distinguished
Feb 24, 2009
3
0
18,510
I took your advise and removed the power supply. I checked the PSU on the bench with power and found that the fan grill had a small voltage running across it. It seems to be coming from one of the screws used to hold the grill in place.

Looks like it's time for an RMA.

Thanks for your help.
 

croc

Distinguished
BANNED
Sep 14, 2005
3,038
1
20,810


You might, while waiting for your PSU, also want to check the circuit that you are plugging in to. From your AC gnd to your earth gnd, there should 0 VAC, and 0 ohms. If this is not the case, your new PSU will also exhibit this behaviour. Your PSU should be case grounded, and it in turn case grounds your chassis.