Elgato Game Capture HD60s does not work with USB 3.1 port

Nov 7, 2018
1
0
10
0
Hello PC, tech, and gaming enthusiasts! I have encountered a problem today with my Elgato HD60 that seems to have no solution. I just plugged my capture card up to my PC for the first time in a few months due to the fact that I am once again getting into the world of YouTube. The main problem I am suffering from is when I start up the software to record, it says that I need to connect my capture card when I already have it plugged into my single USB 3.1 port in the back of my computer (using USB A to C). My capture card also flashes red, and the light moves from the bar being completely filled to fading into one center light. Sometimes this motion repeats, other times it does not. When I move the USB to a regular slot (vs a 3.1 slot) it simply says "This device requires a USB 3.0 slot in order to capture" or something along those lines (which I then connect it to a 3.1 slot and it says to connect my card). Below I am going to list all of the procedures I have tried so far and explain them each. I think I should also mention I am running windows 10...

- The first procedure I took was restarting my system. Obviously this did not help

- I made sure every single driver in my entire system is up to date and running smoothly.

- I looked at the USB slot in BIOS, and this, in my opinion, was the most confusing thing I've seen so far:
When I hook up the USB Cord and the capture card to a regular USB slot, the motherboard recognizes it as the component it is. When I plug it into the 3.1 slot though, the motherboard simply says there is nothing plugged in. I tried switching out the USB C cords that connect the card to the PC, but the same thing happens. Still in BIOS, I hooked up my phone to both cords I tested and the motherboard recognised it on the 3.1 slot and the regular slots (my phone uses USB C). At this point, I really am mindboggled and I can't figure out what is going on

- Next, I left the capture card unplugged for a few minutes, and plugged it back in (Elgato claims this resets the card) which did absolutley nothing

- I also plugged my mouse into the 3.1 slot which ended up working exactly as I expected. The mouse worked just as it usually does with no problem whatsoever and BIOS also recognised it the same as it would on any other slot.

- Finally I went into device manager, which would only recognise the capture card when hooked up to a USB other than the 3.1, and chose to uninstall everything related to the card and also the device itself. I then restarted my system and reinstalled all drivers for the card. This made things even worse for a hot second (card wouldent even recognise under a regular USB slot in the elgato software) but after a minute or two I'm back to the starting line.

* I think it's very important to mention that the light sequence I noted at in the first section is not listed anywhere online or in the card's instructions. I have no clue what is going on

Thanks to everyone who offers support and I will do my best to stay active on this post when not in school for the next few days or until this is solved. Thanks again everyone!
 

Similar threads


ASK THE COMMUNITY

TRENDING THREADS