Question EliteBook Folio 9470m - BIOS Update Help!

xfile102

Distinguished
Dec 24, 2008
80
0
18,630
0
HP EliteBook 9470m, Board: 18DF, BIOS: 68IBD Ver. F.44

Upgraded laptop to 16GB RAM and 1TB SSD. The install of Windows 10 Pro took almost 7-8 times as long as normal, which was weird. However, once installed, worked greats for 4 days. Then it crashed with a BSOD for "Critical Process Died".

Attempted:
Safe Boot: Failed
Power Bleed then Boot: Failed
Tried Windows "Reset" option: Failed
Tried Reset deleting all my data: Failed
So, in desperation, tried to reinstall Windows 10. The laptop wont boot from USB. Tried changing boot..

Legacy Only: Failed
UEFI Hybrid: Failed
UEFI Only: Failed

Tried booting from both an UEFI Install USB, and a Legacy install USB. Neither will work.

Attempted BIOS Update to F.73 Rev.A following HP download.

Ran installer on separate Win 10 Pro Machine
Selected Create Bootable USB option
Created USB
Inserted USB into laptop and booted: BIOS Update Failed
I figured that maybe the jump from V F.44 to F.73 was too much, aas there may have been big changes in subsequent versions prior to F.73.

Downloaded F.62 Rev.A & Made bootable USB: BIOS Update Failed
Downloaded F.69 Rev.A & Made bootable USB: BIOS Update Failed

Even tried manually setting up the BIOS USB with instructions off the HP site, with the following structure:

├── Hewlett-Packard
│ ├── BIOS
│ │ └── New
│ │ ├── 68IMT.BIN
│ │ └── 68IMT.sig
│ └── BIOSUpdate
│ ├── CryptRSA32.efi
│ ├── CryptRSA.efi
│ ├── HpBiosUpdate32.efi
│ ├── HpBiosUpdate32.s09
│ ├── HpBiosUpdate32.s12
│ ├── HpBiosUpdate32.sig
│ ├── HpBiosUpdate.efi
│ ├── HpBiosUpdate.log
│ ├── HpBiosUpdate.s09
│ ├── HpBiosUpdate.s12
│ └── HpBiosUpdate.sig
└── HpBiosUpdate.log

BIOS Update Failed.

System will still not boot. For further troubleshooting, I started the HP Hardware diagnostics, and on the RAM test, it crashed at 6%. Repeated the process 3 times, reseating RAM, same results.

Replaced RAM with a known working 8GB stick, passes Memory Test.

With a good stick of memory installed, repeated the processes above, SAME RESULTS.


How can I get this BIOS updated?? This is driving me up the wall, and causing issues. Advice?
 

ASK THE COMMUNITY

TRENDING THREADS