[SOLVED] Enable AMD-V in Win7 without BIOS or UEFI?

Jun 10, 2019
2
0
10
0
Is there a way to enable AMD-V virtualization in Windows 7 Home Premium (SP1) without going into the BIOS or using UEFI?

Background:
I have an older Toshiba Satellite C875D-S7225 laptop that I purchased new in 2012. It came with Windows 7 Home Premium installed. Starting in 2015, I began using a programming environment called SAS University Edition running in a Linux virtual machine. The virtual machine was run under VMWare. Everything was running fine for several years even after repeatedly installing newer versions of the software.

I recently "upgraded" my laptop to Windows 10. My SAS University Edition programming environment ceased to work. Whenever I would start VMWare, I would get the message "This host supports AMD-V, but AMD-V is disabled." I then tried Oracle Virtual Box but got essentially the same message.

A bit of research turned up that the way to enable AMD-V virtualization is either through the BIOS or through UEFI. My laptop is a pre-UEFI version, so, as far as I can determine, UEFI is not an option. I tried going through the BIOS, but there is no such option under the BIOS setup. I upgraded the BIOS to the most recent available version (v 6.10), but there is still no option to enable AMD-V, and, believe me, I have looked through every possible option/combination of options in the BIOS set up.

I then did a recover back to Windows 7 hoping that whatever turned off AMD-V during the Windows 7 to 10 upgrade process would be reversed. No such luck. Windows 7 is back up and running, but I'm still getting the "This host supports AMD-V, but AMD-V is disabled" message.

I then popped out the CMOS battery hoping to flush the NVRAM. If my SAS University Edition worked before, without my ever having messed with the AMD-V setting, then surely the default setting must be AMD-V enabled and flushing the NVRAM would presumably re-enable that default. Apparently not. I believe I flushed the NVRAM correctly because I had to re-set the system date and time, but I'm still getting the "This host supports AMD-V, but AMD-V is disabled" message.

I've spent a lot of time on the phone with Dynabook (Toshiba's support provider), but they have been unable to help me.

I've downloaded a utility from AMD, amdvhyperv.exe, but all it does is to confirm that AMD-V is not enabled. I've also downloaded Microsoft's Hardware Assisted Virtualization Tool (havdetectiontool.exe), but again, it just confirms that AMD-V is not enabled.

So, my question is: Is there a way to enable AMD-V in Windows 7 Home Premium without going through the BIOS or UEFI?

Other details:
Manufacturer: Toshiba
Model: Satellite C875D-S7225
Processor: AMD A6-4400M APU with Radeon HD Graphics, 2.7 GHz
RAM: 6.00 Gb
System type: 64 Bit
Windows 7 Home Premium, Service Pack 1

Thank you,

Jim
 
Jun 10, 2019
2
0
10
0
Did you look for it under another name like "Virtualization Technology" or "SVM"?

Issue may also be with the fact you are using Windows Home and not Pro or Enterprise.

Did you check with SAS support?
I did check all of the options in my BIOS set up including Power, Security, and Advanced.

I have however now found a fix, or at least a work-around. I reverted back to an older version of VMware (old version = 12; current version = 15) which I still had an installer for. Somehow version 12 must not be using hardware virtualization because everything is working fine now as of about half an hour ago.

I never did figure out how to enable AMD-V.

Jim
 

ASK THE COMMUNITY

TRENDING THREADS

Latest posts