[SOLVED] Enabling FreeSync without using Radeon Software?

Apr 20, 2020
10
1
15
0
Basically, I kept having black screens and unstable overclocks when installing the AMD drivers and software included so what I did was installing the drivers through device manager so I can get rid of the software itself but still have the necessary drivers installed. The problem is that I get screen tearing even though I have FreeSync activated on my monitor. I also enabled Variable refresh rate in Windows settings. My thoughts are that the Freesync is somewhat deactivated or the monitor is bad. Is there any way I can activate FreeSync without using the AMD software?
Specs:
Intel Core i5 9400-F
RX 5600 XT -- I use a BIOS mod to bypass the overclock cap, therefore it is overclocked to 1970 MHz core clock/ 1057 mV core voltage with 1926 Mhz memory clock. The overclock is stable.
1x 1TB HDD + 240GB SSD
700W EVGA Bronze PSU
ASUS PRIME B360 PLUS MOBO
One monitor is an Acer KG241 which is connected through a display port cable. Did not try to check if FreeSync works on this monitor yet, however, I tested AC Valhalla on my other monitor which is an Electriq 1440p 95HZ. The monitor is connected through an HDMI cable and FreeSync is activated in the monitor's settings, but it does not work. The resolution I was playing the game at was 2048 x 1152.
 
I stand corrected then. As for the freesync, if you enable it in your monitor, it is enabled in the drivers as well. At least for me that's how it is.
I just confirmed it btw. I disabled it in both the monitor and adrenaline and then enabled it only in monitor and it was also automatically enabled in adrenaline.
 
I am pretty sure that you have generic drivers installed and not ones that can boost the gpu to advertised speeds.

By modifying the BIOS, you probably made the GPU unable to work with amd drivers which results in the black screens/unstable overclocked. You should revert to the original bios and by undervolting and overclocking you will have better results.
 
Apr 20, 2020
10
1
15
0
I am pretty sure that you have generic drivers installed and not ones that can boost the GPU to advertised speeds.

By modifying the BIOS, you probably made the GPU unable to work with AMD drivers which result in the black screens/unstable overclocked. You should revert to the original bios and by undervolting and overclocking you will have better results.
I downloaded the latest AMD drivers from their website and installed them using the device manager. The BIOS works fine, and I'm getting the correct speeds for both core and memory. I will send you a link to a video which shows how i installed the drivers using the device manager.
View: https://www.youtube.com/watch?v=IhBLqTVxcBM
 
I stand corrected then. As for the freesync, if you enable it in your monitor, it is enabled in the drivers as well. At least for me that's how it is.
I just confirmed it btw. I disabled it in both the monitor and adrenaline and then enabled it only in monitor and it was also automatically enabled in adrenaline.
 
Apr 20, 2020
10
1
15
0
I stand corrected then. As for the freesync, if you enable it in your monitor, it is enabled in the drivers as well. At least for me that's how it is.
I just confirmed it btw. I disabled it in both the monitor and adrenaline and then enabled it only in monitor and it was also automatically enabled in adrenaline.
sorry for the late reply. I guess my monitor is at fault then. I will just play with v-sync activated in singleplayer and leave it off when playing multiplayer.
 

ASK THE COMMUNITY

TRENDING THREADS