[SOLVED] Enabling G-Sync with EVGA RTX 2080 and Asus PG279Q

marek_shields

Distinguished
Nov 21, 2012
57
5
18,545
4
Hello folks,

I am having a bit of an issue actually getting G-Sync enabled on my rig. I have an Asus PG279Q monitor, and an older Dell monitor, with an EVGA RTX 2080 card. I went in the nVidia control panel, selected "Enabled G-Sync, G-Sync Compatible" and "Enable for windowed and full screen mode" from the "Set up G-SYNC" menu for the Asus monitor. I then went to "Manage 3D Settings" and I see that "Monitor Technology" is set to G-SYNC. Under the Vertical Sync setting however, I only see "Use the 3D application setting", "Off", "On", and "Fast" as an option where in some tutorial videos online I have see "G-Sync" as an available option. I did a clean install of the latest graphics drivers but that didn't seem to help. I honestly have no idea what I am doing wrong here and and advice on how to fix this would be greatly appreciated.

Edit: There are 3 reasons why I think G-Sync isn't actually enabled. First being that when I select the "G-SYNC Indicator" from the Display section on the nVidia Control panel, nothing shows up. Second, when I run the G-Sync Pendulum test, the only options I have are to turn V-Sync on and off. G-Sync immediately goes back to one of the V-Sync options. Third, the UFO frame rate test isn't ever able to sync the frame rate and complains as such.
 

marek_shields

Distinguished
Nov 21, 2012
57
5
18,545
4
After unplugging that other monitor, restarting the computer, enabling the G-Sync indicator, then re-launching the pendulum test app, it seems to be working now. Plugging back in the second monitor and restarting the computer again still has G-Sync working. Apparently I just didn't reboot it enough times or something :)

Also of note for those who might read this, the G-Sync indicator only shows up for G-Sync enable applications (apparently just having a G-Sync enabled monitor isn't good enough to show that indicator). Another thing to note is that the vertical sync settings no longer have "G-SYNC" as an option. You can set it to allow the applications to choose what to use which seemed to work fine for me.
 

ASK THE COMMUNITY