Entering motherboard (ASUS TUF X299) uefi instead of booting

Sep 5, 2018
3
0
10
0
Asus TUF X299 MARK 2 LGA2066, Intel X299 - UEFI version 1004
SSD & SATA installed (and recognized)

After putting together this desktop computer, I have been playing around with its BIOS/UEFI. Still no internet connection, so I downloaded the newest BIOS for the motherboard (version 1401; https://www.asus.com/us/Motherboards/TUF-X299-MARK-2/HelpDesk_BIOS/) and plugged it with a USB stick. Restarting, the computer went again to the 1004 version, even though it recognizes in the booting order the USB (before the two hard-drives). Same story when I made a bootable USB stick (using rufus) with a linux ISO on it - the computer just goes to the motherboard UEFI, even though the USB with the linux ISO is recognized at the top of list of the booting order...

How do I let it actually boot instead of going to the motherboard UEFI?
BTW. I don't know if this is important, but I get a "CPU fan error detected. Ensure that the CPU fan is properly instaled on the CPU_FAN header or adjust/disable the Fan Speed Low Limit option the UEFi BIOS. Press F1 to Run SETUP" error message. On pressing F1 I enter the motherboard UEFI. All my fans are running properly....
 

Lutfij

Titan
Moderator
The pen drive should hold the base BIOS file in it's root directory(meaning no folders) and the pen drive should be FAT32 formatted. It should also be plugged into the BIOS FlashBack USB port. On second thoughts, you should gradually work your way up to 1401 instead of jumping from 1004 all the way to 1401.

How are your fans connected to the motherboard? Are you using an AIO?
 
Sep 5, 2018
3
0
10
0
Thanks for the reply and the suggestion, Lutfij. None of the USB ports are marked as with BIOS. The USB stick was prepared by rufus, so it has no folders and is a completely bootable, single-purpose flashdrive. I've had success installing linux (ubuntu) this away on a laptop.

Yes, I'm running an AIO.

 
Sep 5, 2018
3
0
10
0
Thank you for the reply. Nope, the USB flash drive was set to UEFI. I found another boot menu in my motherboard's UEFI, and changed some of the permissions from "Legacy only" to "UEFI first", but I don't think that made a difference, because the bootable disk was already identified earlier, except the computer doesn't boot to it. However, I did manage to find out I can double-click on the bootable options. Doing that, now something is actually happening. Nothing good (some sort of crush), but I think the computer is actually trying to now install ubuntu. Stay tuned.

 

Similar threads


TRENDING THREADS