Entering the bios problem

Status
Not open for further replies.

kalvus5

Distinguished
Oct 30, 2011
43
0
18,530
Hey guys so I have a GA-Z68X-UD3H-B3 and I've been wanting to overclock my i5 2500k but everytime I try to enter the bios, it just does not seem to work. I'm given the choices at the startup screen of POST-TAB BIOS Setup-DELETE and the other options, but when I press delete on startup, the computer does not even register my keystrokes and It boots up normally, however, if I press the TAB button, it takes me to the POST screen, but for only a few short seconds, and continues to boot up normally. So I tried again, and I pressed the TAB button, went to the post screen, and spammed the delete button trying to get into the BIOS setup, but that did not register either. What am I doing wrong? Any help is appreciated.

BTW I'm using an iMac aluminum wired usb keyboard.
 
Solution
Mac keyboards don't have an official standard DEL key.
Allthough the workarounds described by Apple should work, but ONLY with Apple hardware (laptops/desktops eg.).

My suggestion: buy the cheapest ps/2 or usb keyboard at your local computer shop.
Even if you keep using the Apple one it's handy to have a spare one.

COLGeek

Cybernaut
Moderator
Do you have a regular PC keyboard? If so use it to adjust your BIOS. If not, try this. Restart your system, before it begins to reboot (before the BIOS splash screen pops up), place your hand on your keyboard holding down several keys at once. This should trigger a keyboard error and force the system to take you to setup (for the BIOS).

The issue is the different key mapping on the Mac keyboard (I am actually typing this message on one right now).

Good luck!
 

kalvus5

Distinguished
Oct 30, 2011
43
0
18,530
So Colgeeks method did not work, and I made sure my keyboard was plugged into the red ports, which I'm guessing is USB 3.0. The weird thing is I can get to the post screen, so it looks like my keyboard works, but other than that, it leaves the post screen so quickly that I can't even choose the next option, Is there any reason why it does not stay on the postscreen?
 

kalvus5

Distinguished
Oct 30, 2011
43
0
18,530

I held down a bunch of keys when the computer booted up and nothing happened, it continued to boot up normal, I was just holding down a bunch of letters, should I hold down other keys?
 

1foxracing

Distinguished
Feb 14, 2011
119
7
18,715

Red ports are 2.0 & Blue are 3.0. I had a friend with the same problem as you and he had his keyboard plugged into the USB 3.0 port, after plugging his keyboard into the 2.0 ports all was good. His was a AMD system though so maybe that is the difference?
 

kalvus5

Distinguished
Oct 30, 2011
43
0
18,530
oh that is what I meant, the red is 2.0..but it still doesn't work. But like I said, the buttons seem to work, but as soon as I enter the POST screen, it stays there for like three seconds, and no matter what I press, it just goes back to rebooting the computer.
But yeah I'm not sure what to do at this point..I have no other keyboards, except a even older mac keyboard, so I'm sure that will not change anything.
 

MxMatrix

Distinguished
Jan 20, 2012
47
0
18,540
Mac keyboards don't have an official standard DEL key.
Allthough the workarounds described by Apple should work, but ONLY with Apple hardware (laptops/desktops eg.).

My suggestion: buy the cheapest ps/2 or usb keyboard at your local computer shop.
Even if you keep using the Apple one it's handy to have a spare one.
 
Solution
Status
Not open for further replies.