Question Epson BX610FW stopped working and makes strange noises

britpoprule

Honorable
Jul 5, 2015
19
0
10,510
0
Hello everyone,
I have a problem with my Epson BX610FW. All of a sudden it has stopped printing. I can still use it as a scanner, but when I try to print it makes a weird sound (almost like a tractor) and in the end it doesn't print anything, or prints something very badly.
I went to Control Panel to find the printer's icon to attempt the cleaning of the heads (I know it would have been useless) but I can't find that option anymore.
Also the green tick which generally was at the side of the printer's icon is now missing. Weird.
What do you think?

Is it worth repairing a printer? Considering that I don't believe a repair would cost less than £50, and to buy a new one would cost £100.
 
Last edited:
Sep 12, 2020
62
17
45
1
............................but when I try to print it makes a weird sound (almost like a tractor) .............
It's probably badly broken but there are things you could try:

Turn the printer off then disconnect its power. Using a bright torch, see if you can see any foreign objects trapped between the rollers or any other moving parts. The last noisy printer I looked at had what appeared to the remnants of a chocolate-chip cookie inside it.

............................Also the green tick which generally was at the side of the printer's icon is now missing. ............
To get the green tick back, right-click on the printer's icon and choose "Set as default".
 
Reactions: britpoprule

britpoprule

Honorable
Jul 5, 2015
19
0
10,510
0
It's probably badly broken but there are things you could try:

Turn the printer off then disconnect its power. Using a bright torch, see if you can see any foreign objects trapped between the rollers or any other moving parts. The last noisy printer I looked at had what appeared to the remnants of a chocolate-chip cookie inside it.



To get the green tick back, right-click on the printer's icon and choose "Set as default".
Thank you for the answer.
I cleaned the heads (from the printer screen). It asked me to replace the Black cartridge. Replaced, prints perfectly. I print another thing and it gives a message of error on the display. Disconnect/reconnect the cable and it prints again. Still with the loud mechanic noice but it prints again.
Unfortunately it doesn't allow me to look if there is something stuck inside, it's all covered, unless I start unscrewing the parts covering the view.
What should I do? Keep it like this?
 
Sep 12, 2020
62
17
45
1
..........................Replaced, prints perfectly. I print another thing and it gives a message of error on the display. Disconnect/reconnect the cable and it prints again. Still with the loud mechanic noice but it prints again................
Powering off the printer by disconnecting its power lead and leaving it for a few minutes frequently works miracles. You could also try a different USB port or another USB cable if you have one. It's unlikely that any of that will cure the tractor noises though.
 

ASK THE COMMUNITY