Question epson perfection 370 not recognized on my mac (os Catalina)

Oct 25, 2021
2
0
10
0
Hi folks,

All of a sudden, my epson 370 scanner isn't being recognized by my mac. It was working fine a couple of days ago. I just tried to open the application and now the scanner settings window comes up but there's no scanner recognized, even though all the power cords are working. I redownloaded and reinsstalled the driver, restarted the computer but still the same thing. Any ideas as to what to do to solve the issue?

Thanks,
Carl
 

spinningstill

Reputable
Jan 15, 2018
375
19
4,915
49
This is through Wifi? Try restarting your modem/router.

I could not connect my two machines via the network for about a week and decided to try logging into the Modem. I simply logged in and all is good. Sometimes a Modem/Router restart is what is needed.

Grace and peace.
 
Reactions: cqangel
Oct 25, 2021
2
0
10
0
This is through Wifi? Try restarting your modem/router.

I could not connect my two machines via the network for about a week and decided to try logging into the Modem. I simply logged in and all is good. Sometimes a Modem/Router restart is what is needed.

Grace and peace.
Hi Gary, Thanks for the prompt response! My iMac is hardwired into the router, actually, so I don't understand why this is happening. Driving me nuts. The driver reinstalled "successfully," and yet when I open the app, the scanner which is plugged in, still isn't recognized. Should I try wifi?
 

spinningstill

Reputable
Jan 15, 2018
375
19
4,915
49
Would still restart your Router/Modem. Check to make sure the App is authorized in security.

You have unplugged all cables and plugged them back in? Should work hardwired, can try WiFi as a troubleshooting step.

I just threw away a charging cord with no cracks for an iPhone 6, it was not charging on multiple devices.

Have you tried another computer?
 

ASK THE COMMUNITY