Epson R1900 says cartridges are missing

May 26, 2018
4
0
10
0
I'm trying to fix an Epson R1900 photo printer. When all cartridges are installed, it says all cartridges are empty/missing. If I remove one cartridge, it will tell me that one is missing but otherwise operates properly. When I put it back in, it goes back to saying all are missing/empty. It doesn't matter which cartridge I remove/replace. It works properly with 1 to 7 cartridges installed, but when 8 are installed, it says they're all gone. I'm using genuine Epson cartridges and have tried two sets.
I replaced the chip board and the ribbon cable that goes from the chip board to the main board. I've tried all sorts of "tricks" I found online but no joy. This one has me stumped.
If it helps, I've noticed that when all cartridges are installed and it's doing its normal startup routine, the print carriage pauses at the left side of the machine for about 20 seconds. That doesn't happen with one cartridge missing.
Hope someone has some thoughts on this.
 

ASK THE COMMUNITY