[SOLVED] ERR_GFX_D3D_INIT error in GTA 5

Page 2 - Seeking answers? Join the Tom's Hardware community: where nearly two million members share solutions and discuss the latest tech.
Aug 10, 2019
17
0
10
0
Go to Power Plan > Advanced Power Settings > Intel graphics settings > intel graphics power plan - set for max performance
The gpu power settings can be set in Nvidia control panel.

This may help on the Direct X matter:
https://www.lifewire.com/how-to-download-install-directx-2624489
okay so a one small miracle happened. In Nvidia Control Panel if I only use Intel Graphics globally and for the game also it works good. The error doesn't show up but if I switch that back to normal so that NVidia GPU can take over the error occurs.

Now just pushed intel's gpu to max performance as you said so let's see what happens. And also downloaded the DirectX from the link you shared.

Meanwhile do let me know why it is only giving error while allowing to switch to NVidia?
 

Phaaze88

Reputable
Herald
It's a common issue with laptops. Desktops - nada.
Between the two, it's gotta be some crap software... oh, well whaddya know, it must be that Nvidia Optimus software that desktops don't have.
I could also say it's Rockstar's Social Club, but since some desktop users also run SC instead of Steam and not have issues with it, I can only look at Optimus being at the center of it all.

I have found a couple of workarounds - but they're pretty old - but they may still work.
1st one:
"u have to manually tell nvidia control panel to use the high performance graphics card

Right click the GAME Icon >> Run With ... >> Nvidia GPU. "
2nd one:
"Go to your device manager and turn off your Nvidia card.

Now start the Launcher, when it comes up, wait till the loading circle is showing, at that moment turn on your Nvidia card again.

Just before it starts the game.. It starts in Windowed mode, but you can set it to fullscreen ingame."
 
Aug 10, 2019
17
0
10
0
It's a common issue with laptops. Desktops - nada.
Between the two, it's gotta be some crap software... oh, well whaddya know, it must be that Nvidia Optimus software that desktops don't have.
I could also say it's Rockstar's Social Club, but since some desktop users also run SC instead of Steam and not have issues with it, I can only look at Optimus being at the center of it all.

I have found a couple of workarounds - but they're pretty old - but they may still work.
1st one:
"u have to manually tell nvidia control panel to use the high performance graphics card

Right click the GAME Icon >> Run With ... >> Nvidia GPU. "
2nd one:
"Go to your device manager and turn off your Nvidia card.

Now start the Launcher, when it comes up, wait till the loading circle is showing, at that moment turn on your Nvidia card again.

Just before it starts the game.. It starts in Windowed mode, but you can set it to fullscreen ingame."


Cool man! I'm able to play this game with Intel GPU. After that, as you mentioned, I switch the whole thing back to Nvidia and I guess it goes fine with it. I have played for longer hours without any interruption and now it feels satisfactory.

Thank you so much for sticking with me for every trivial step, I really appreciate it and you have helped me remove my thoughts about not to feel bad about buying this computer. Thanks a ton once again. :)
 

Phaaze88

Reputable
Herald
Cool man! I'm able to play this game with Intel GPU. After that, as you mentioned, I switch the whole thing back to Nvidia and I guess it goes fine with it. I have played for longer hours without any interruption and now it feels satisfactory.

Thank you so much for sticking with me for every trivial step, I really appreciate it and you have helped me remove my thoughts about not to feel bad about buying this computer. Thanks a ton once again. :)
I, myself, am glad it worked out for you! Others haven't been as fortunate.
 

ASK THE COMMUNITY