Question Error-checking a new Ryzen 3 build

Apr 23, 2020
3
0
10
0
Hi Tom's Hardware community!

Here's a new build I began to put together today. I haven't been able to successfully POST, but all connected fans power up and run continuously.

CPU: Ryzen 3 3200G
Motherboard: MSI A320M-A Pro Max
Ram: Kingston HyperX Fury 2x8GB DDR4 2666 Mhz
SSD/HDD: Intel 660p Series M.2 512GB
GPU: Gigabyte RX570 Gaming 4G Rev2.0
PSU: Corsair RM650x
Chassis: Thermaltake H17

Here are the steps I've taken so far (*according to "shortstuff_mt's" list)

  1. Read MB manual
  2. Ensured CPU power connector plugged in (4pin on this board)
  3. Standoffs in place and fit MB exactly (micro-ATX MB and case)
  4. Video card fully seated...
  5. ...and connected to PSU.
  6. Tried booting with one and two RAM sticks, all slot configurations
  7. Double-checked RAM insertion
  8. Double-checked RAM slot usage
  9. CPU installed correctly, and reseated...
  10. (cont'd)...
  11. (cont'd)...
  12. (cont'd)...
  13. Stock cooler installed - no film...
  14. ...and mounted correctly.
  15. Checked for loose screws or wires
  16. Worked on wooden table, wooden floor, no socks, touched case and other grounding objects repeatedly.
  17. Installed system speaker that came with the case. No beeps when CPU/HSF/RAM/GPU/PSU all connected. Three long beeps when booted without RAM.
  18. Tried booting with and without front panel plugs connected, same result either way. Case power LED did not come on even when reversing polarity.
  19. PSU switch on :)
  20. This CPU / MB combo should be compatible - MB box has the Ryzen 3000 ready badge. MSI's website lists the two as compatible as well.
  21. I have NOT YET tried resetting CMOS.
  22. I've tried both integrated video and video card display outputs.
  23. Double-checked all cables.
This is the first PC I've built from scratch, though have troubleshooted others. As such, it's a bit more nerve-wracking...

Some questions:
  • Is my motherboard dead or is another component the problem?
  • Any glaring compatibility issues? RAM, perhaps?
  • Despite the badge, is it possible the BIOS of this MB is not actually updated?
  • Any other ideas?
Any and all help is much appreciated :)
 
Apr 23, 2020
3
0
10
0
Thanks for the reply NightHawk! I tried that a couple times, with the same effect - three beeps without RAM, silence with RAM

Compatibility update:
- MSI website lists my RAM / CPU / GPU / PSU as compatible with the A320M-A Pro Max
 
Apr 23, 2020
3
0
10
0
PROBLEM SOLVED:

Ram was not compatible with the motherboard BIOS (ram released much more recently). Updated BIOS using different ram and now everything works.
 

ASK THE COMMUNITY

TRENDING THREADS

Latest posts