Question Errors and BSOD when trying to run 3200mhz ram on ryzen 5 2600

lockdown744

Reputable
Sep 14, 2017
145
5
4,695
4
Hey guys I need some help,



I bought a 2x8gb avexir core 2 3200mhz kit last year and during that time I was able to run the ram at 3200mhz with no problems. However a few days ago I experienced bsods that show codes relating to a faulty ram so I tried to run memtest 86 and hci memtest.



First I tried to run memtest86 on each of the ram. @3200mhz there were no errors at all but if I test both of the sticks at the same time errors are showing up specifically at test #8. Although on my second attempt to test both the sticks at the same time no errors showed up at all. So after that I immediately ran HCI memtest but at around 20% it already showed up errors.



Next I tried to lower the speed to 3133mhz. In memtest86 this speed showed up errors too and on the same test also test #8 however no errors showed up at HCI memtest up to about 400-450%. Furthermore I also experience a bsod at this ram speed that relates to a faulty ram


Lastly(and my current configuration right now), I lowered the speed of the ram again to 3066mhz. It showed up no errors for both memtest86 and HCI memtest. I have yet to experience a bsod in this speed, I have been running this 3066mhz only for 3 days as of the moment.



So the question in my mind right now is, has my cpu degraded already? (I haven't tried to overclock it yet since I am still using the stock cooler) or is my ram faulty and/or degraded to the point that it can't run at 3200mhz anymore even though it was rated for that speed? (if ram degradation is even possible)



Hope that someone can help me here



P.S. my motherboard is a b450 steel legend and I have tried to update the bios already but still experienced the same problems. All of the ram slots in the board are also working.
 

ASK THE COMMUNITY

TRENDING THREADS