Question Ethernet and Wifi Connection will not work unless connected to specific Router

Apr 4, 2020
1
0
10
0
Okay, I've just spent the better part of my evening troubleshooting the strangest connectivity issue I've ever seen.

I have been using a Netgear Nigthhawk AC1900 router for about 2 years now. In the midst of the ongoing COVID-19 crisis I am working from home (SQL Developer). Over the last 2 weeks working from home I have had intermittent WIFI issues with my work laptop that sorted themselves out after a few minutes or hours, however I could always disconnect from the router and connect directly to the work laptop or my personal PC through the Ethernet from my ISP provided SmartRG modem. Since the Ethernet always worked, I figured that the router was starting to go bad so I purchased a Netgear NightHawk XR500 router to replace it. That router arrived yesterday, and this evening when the WIFI once again dipped out, I decided to go ahead and change them out. So I turned off and disconnected the AC1900 router, and power cycled the SmartRG modem, then I connected the Ethernet to the XR500 and powered it on. It turned on and began processing, and then after a couple of minutes opened the setup dialog. I noticed that the Internet light on the XR500 was still RED, but I thought that may be because it was not configured yet.

Anyway, I went through the setup and got to the point where the XR500 was looking for an internet connection and it failed to find one. So I tried power cycling both the modem and the router again to see if that helped, it did not. So I turned off the XR500 router and connected the Ethernet straight into my personal computer. It has a Killer E2400 Gigabit Ethernet Controller for networking. However, once I connected the Ethernet to the computer the internet was still not working. Looking at the modem the Internet light was green and everything looked just how it always does. At this point I turned off the modem and unplugged it for a few minutes, and then plugged it back in to see if maybe the lights were not updating correctly. Once the modem went through it start up process all the lights came back on green, however the computer still did not have internet.

Grasping at straws now, I went and got a new Ethernet cable and tried to connect to the computer with that, however that also did not work. Now out of ideas I called my ISP service number and spoke with them. They were able to remote into the modem and from their end everything looks fine. They did have me diagnose the connection on my end using the Network Connections window in Windows 10. The Diagnose tool returned a message that the Ethernet did not have a valid IP Configuration. The service tech opened a ticket for a technician to come out sometime next week if I was unable to resolve the problem on my end. After getting off the phone, I started googling that error message and found this link through Google: https://windowsreport.com/ethernet-valid-ip-configuration-windows-10/

I tried several of the solutions on that page Including Solution 5 and Solution 16. I also tried using the Network Reset option in Windows 10. However, none of these solutions fixed the issue. Now confused on whether my computer's Network card may be the issue, and that perhaps the internet may have been down on the ISP's side when I attempted to setup the XR500; I reconnected the XR500 and tried setting up over WIFI on both my iPhone 8 and another PC that uses a Wireless Network adapter. In both instances the setup once again failed when connecting to the internet. As one last test to see if maybe the router was bad and my network card was going bad in my main system, I pulled out my work laptop and connected it the modem via Ethernet, again with no luck. Now at a complete loss, and as a total shot in the dark, I reconnected the AC1900 router and...it was able to connect to the internet just fine. Once I saw that it was working with the old AC1900 router, I copied down the MAC address from the router, and turned it off. Then I reconnected the new XR500 router and tried to go through the setup again on my main PC that just had internet through the old router. Again it failed when attempted to connect to the internet, this time I entered the MAC address from the old router and attempted to get the XR500 to connect using those settings sadly this again did not work. So I reconnected the old AC1900 router one more time...and it again connected right up.

I am at a complete loss right now. I have no idea why I would need to be connected through the old AC1900 router in order to connect via Ethernet. Just for extra info, I had the AC1900 before I got the new SmartRG modem. It is maybe 2 months old that this point, we received when we upgraded to 100Mb internet.

Any help you folks can offer would be greatly appreciated I go back to work Tuesday and I really don't want to be stressing over having a secure reliable internet connection to work on in addition to everything else. I also really don't want to have a service technician in my home at the moment.
 
Interesting issue. Thank you for all the details!

I'm sure you've thought of this, but it seems like your isp wasn't releasing the IP address to your ac1900 and wouldn't allow anything else to connect. Even with a mac clone, I've still seen this happen unless you manually release the wan dhcp address in the ac1900, and then connect the new router and let it pull an address. Even when doing this though, I would recommend a mac clone simply to keep your same wan IP address since you know it was working. Try this and see if it helps.

As far as your computer, boot up a linux live cd and see if it will pull an IP address. I hate how windows can get messed up with something as simple as an ethernet disconnect and reconnect, but it does happen. If the linux works, then you know it's not a networking issue, but just a windows issue.
 

ASK THE COMMUNITY

TRENDING THREADS