Question Ethernet and Wifi not allowing certain online connectivity and downloads ?

Mar 31, 2021
1
1
15
0
About a month ago I moved to a new home but kept my old router/modem combo and the same internet provider. Since moving I have been having odd connectivity issues. I can connect my PC to ethernet and wifi no problem and doing mostly everything on my PC has been fine. I can play League of Legends, use the internet, Youtube, etc.

I can download Battle.net just fine but when I try to download any games they won't even start downloading.
I can connect my Nintendo Switch to my Wifi just fine and it says connected to the internet on the device but when playing games on the Switch I can't go online to play with other players. (I get NAT type F).

I tried to play Among Us today on my PC and phone (I tried ethernet and wifi) but get an error about not having a reliable packet.

I believe all of these problems have to do with my internet connection as I connected to a neighbors guest wifi and I can now play Among Us fine and Battle.net is able to download World of Warcraft.

Does anyone have any ideas on what is wrong and how can I fix it? I tried hard resetting my router/modem combo and it didn't help.
 
Reactions: bniknafs9

kanewolf

Titan
Moderator
About a month ago I moved to a new home but kept my old router/modem combo and the same internet provider. Since moving I have been having odd connectivity issues. I can connect my PC to ethernet and wifi no problem and doing mostly everything on my PC has been fine. I can play League of Legends, use the internet, Youtube, etc.

I can download Battle.net just fine but when I try to download any games they won't even start downloading.
I can connect my Nintendo Switch to my Wifi just fine and it says connected to the internet on the device but when playing games on the Switch I can't go online to play with other players. (I get NAT type F).

I tried to play Among Us today on my PC and phone (I tried ethernet and wifi) but get an error about not having a reliable packet.

I believe all of these problems have to do with my internet connection as I connected to a neighbors guest wifi and I can now play Among Us fine and Battle.net is able to download World of Warcraft.

Does anyone have any ideas on what is wrong and how can I fix it? I tried hard resetting my router/modem combo and it didn't help.
Start by manually overriding your DNS. 8.8.8.8 and 8.8.4.4 are the google DNS servers.
 

ASK THE COMMUNITY

TRENDING THREADS