Question Ethernet connected to internet, but connection times out and can't go online

Oct 29, 2020
3
0
10
0
Hi
My internet works just fine when I use WiFi but when I connect to my router with my ethernet cable it says connected but I can't access websites or use any other application that requires the internet. My PC claims I'm connected to the internet and the lights on my ethernet port are green, when I'm connected with via ethernet. I've tried resetting my network but that doesn't seem to help either.
 
Last edited:
I tested the same cable with another pc and it worked with that.
Start with a shutdown of the system, the router and the modem for 10 seconds. Plug the modem first. Then router. Then start the PC. If it's still not working you could try installing the latest LAN drivers for your board and if that doesn't work it could be your OS that is corrupted or infected. Could be the Ethernet port that is broken or just loose. I had a few loose LAN port where the light was green and the internet was not working and sometime "connected but limited". Sometime the light was orange because of the loose port and port was dropping to 100MB.
 
Reactions: Jerr123
Oct 29, 2020
3
0
10
0
Start with a shutdown of the system, the router and the modem for 10 seconds. Plug the modem first. Then router. Then start the PC. If it's still not working you could try installing the latest LAN drivers for your board and if that doesn't work it could be your OS that is corrupted or infected. Could be the Ethernet port that is broken or just loose. I had a few loose LAN port where the light was green and the internet was not working and sometime "connected but limited". Sometime the light was orange because of the loose port and port was dropping to 100MB.
Will try this and see if it works. Thanks!
 

ASK THE COMMUNITY

TRENDING THREADS