Question Ethernet Controller drivers are not installed; I can't find/install them (ASUS Maximus XI Formula Z390)

apalio

Commendable
Apr 25, 2016
61
0
1,660
5
Hello everyone, I'm having an issue with my ethernet controller. In Device Manager, under 'Other devices,' the Ethernet Controller has the yellow triangle with the exclamation point. When I click properties, it says "The drivers for this device are not installed. (Code 28)"

My internet works and has been working, however my ethernet port will randomly disconnect and reconnect about 10-30 seconds later. I believe this may be causing it, which is what brought me here.

When I try to update the driver and search automatically, it doesn't find anything. I went on to the motherboard's manufacturer site (ASUS), and downloaded the LAN driver. I extracted the files, but when I try to run AsusSetup.exe, nothing happens. Normally when installing other ASUS drivers, it goes into a wizard that you click through. This just asks for permission to make changes, I click yes, then nothing happens. I believe this is the driver I need to install for the controller.

Please help. Feel free to ask questions.



The part numbers shown in the Hardware Ids are:

PCI\VEN_1D6A&DEV_11B1&SUBSYS_87721043&REV_02

PCI\VEN_1D6A&DEV_11B1&SUBSYS_87721043

PCI\VEN_1D6A&DEV_11B1&CC_020000

PCI\VEN_1D6A&DEV_11B1&CC_0200



System specs:

ASUS Maximus XI Formula Z390

i9-9900K @5.1GHz (Noctua NH-D15 cooler)

Nvidia RTX 2080Ti

Samsung 960 EVO

EVGA SuperNOVA G3 750W

Windows 10 Pro 1809 | Version 10.0.17763 Build 17763 (Up to date)
 

Similar threads


ASK THE COMMUNITY

TRENDING THREADS