• Now's your chance win big! Join our community and get entered to win a RTX 2060 GPU, plus more! Join here.

    Pi Cast Episode 3 streams live on Tuesday, August 4th at 2:30 pm ET (7:30 PM BST). Watch live right here!

    Catch Scharon on the Tom's Hardware Show live on Thursday, August 6th at 2:00 pm ET (7:00 PM BST). Click here!

Question Ethernet disconnects after being idle for 6 minutes

Jan 25, 2020
So I am at my wit's end. This issue started happening a few weeks ago. I left my PC to eat lunch and when I came back it had the warning icon on the internet symbol in the task area. At first I tried to just disable and enable the adapter but it wouldn't let me. It would say enabled but it wasn't really. Then I restarted. BSOD. Driver Power State Failure.

After I booted, I thought the problem was gone, but it wasn't. If i leave the computer alone for a few minutes the problem starts again. What's really weird is that if I try to shut it down, it shuts down, but my tower still has a light + my keyboard as well (also when signing out, switching accounts etc). This doesn't happen if the problem isn't there. So every time I booted up (the problem doesn't start until I leave it alone) I tried various ways to induce the problem. When I try to disable the adapter, it gets disabled, but the problem starts when I try to enable it again. In fact, doing ANYTHING to the adapter causes the problem. It hangs trying to uninstall the driver, using a VPN, etc. I also uninstalled a lot of stuff that I thought was the problem (VPN, packetstream, etc.) The event viewer is also of no help, I think. Another problem I noticed is that if I try to enable airplane mode, the option to disable it is grayed out.

The problem does not persist in safe mode, or in another account, which indicates it is a software problem. So I tried my next idea: uninstalling then reinstalling the drivers on the other account where everything is normal. Welp, the problem still persists even with a reinstalled driver. I also turned off all the power saving stuff related to the adapter. Any ideas? I'm in the middle of college right now so I can't afford wasting time on this problem. Resetting might fix it but I have sensitive files and I would rather not have to deal with reinstalling everything during the school year. Help. I literally have no idea what to do.

Windows 10
Version 10.0.17763 Build 17763
Realtek PCIe GbE Family Controller


Win 10 Master
Try a clean boot and see if it changes anything - make sure to read instructions and make sure NOT to disable any microsoft services or windows won't load right - https://support.microsoft.com/en-au/help/929135/how-to-perform-a-clean-boot-in-windows

if clean boot fixes it, it shows its likely a startup program. You should, over a number of startups. restart the programs you stopped to isolate the one that is to blame.

Are you still getting BSOD? If so, can you follow option one on the following link - here - and then do this step below: Small memory dumps - Have Windows Create a Small Memory Dump (Minidump) on BSOD - that creates a file in c windows/minidump after the next BSOD

copy that file to documents

upload the copy from documents to a file sharing web site, and share the link in your thread so we can help fix the problem