Question Ethernet disconnects when put to sleep

Samule1234

Prominent
Jul 10, 2020
44
3
545
1
Hi,

I built a computer about a year ago and ever since the thing has disconnected itself from ethernet every time it is put to sleep. It is extremely annoying to wait for it to auto connect back each time it wakes up. I've tried many things like changing settings in device manager to stop it from being able to turn off to save power and it still does it. Any ideas?
Thanks!
 
Jun 15, 2022
4
0
10
0
Right click --> windows icon(start menu) --> settings --> system -->power&sleep -->additional power settings on the right -->change plan settings --> change advanced power settings --> select ultimate performance or high performance

if that doesn't do it, repeat steps above then scroll down and disable usb selective suspend setting or wireless adapter settings set to maximum performance (not ethernet for this part, but similar effect)
 

Samule1234

Prominent
Jul 10, 2020
44
3
545
1
Right click --> windows icon(start menu) --> settings --> system -->power&sleep -->additional power settings on the right -->change plan settings --> change advanced power settings --> select ultimate performance or high performance

if that doesn't do it, repeat steps above then scroll down and disable usb selective suspend setting or wireless adapter settings set to maximum performance (not ethernet for this part, but similar effect)
I checked and I already have all those settings set exactly as you wrote and it still does it.
 
Jun 15, 2022
4
0
10
0
One more simple thing to try. Right click network icon in bottom right -->open network an d internet settings -->change adapter options --> right click ethernet connection -->properties -->configure --> advanced -->disable system idle power saver and maybe enable ultra low power mode

if that doesnt do it, we can try some more advanced options in registry. i have a feeling it should be good though
 

Samule1234

Prominent
Jul 10, 2020
44
3
545
1
I already had that setting off, but I found one called green ethernet that also seemed like it might want to turn it off but I disabled it and it still wont stay connected.
 
Jun 15, 2022
4
0
10
0
On desktop, win + R -> type in devmgmt.msc -> netowrk adapters -> select ethernet -> right click, properties -> under power mgmt, uncheck allow computer to turn off this device to save power->ok, exit out, restart pc.
 
Jun 5, 2022
2
0
10
0
If your computer still loses network connection in sleep mode, open the Device Manager and access the Properties of your Ethernet/Wi-Fi adapter. Make sure the “Allow the computer to turn off this device to save power” option is unchecked. mythdhr
 

ASK THE COMMUNITY

TRENDING THREADS