• Now's your chance win big! Join our community and get entered to win a RTX 2060 GPU, plus more! Join here.

    Pi Cast Episode 3 streams live on Tuesday, August 4th at 2:30 pm ET (7:30 PM BST). Watch live right here!

    Catch Scharon on the Tom's Hardware Show live on Thursday, August 6th at 2:00 pm ET (7:00 PM BST). Click here!

[SOLVED] Ethernet doesn't have a valid IP config

extraproblems

Honorable
May 18, 2014
43
0
10,540
1
Sorry I am typing this on my phone, I hope someone can help me. the other day lightning struck very close to me and it seems as though it fried my ethernet port. the pc (recently built in March) seems to be working fine except connecting to internet(no light on mobo at port).

when I ran troubleshoot, it was telling me to plug in a cable. I tried numerous cables. the modem is lit up and working. I even called my ISP and they said I was online. I bought a network card hoping it would be a fix. I installed nic and tried to connect and got the Ethernet doesn't have a valid IP config error. I hadn't installed drivers yet. I installed drivers and nothing. now I started getting the plug a cable in error, plus the ethernet doesn't have a valid ip config error. I have done the flush dns, netsh reset commands. I tried the turn off fast start.

nothing has worked and it just says Unidentified network in the network connections. I am at a loss and hoping someone can help me.
 

extraproblems

Honorable
May 18, 2014
43
0
10,540
1
UPDATE: the ethernet port is fried and the modem was messed up even though the lights showed it was working properly. I got a new modem and a NIC, and now I'm back online
 

extraproblems

Honorable
May 18, 2014
43
0
10,540
1
UPDATE: the ethernet port is fried and the modem was messed up even though the lights showed it was working properly. I got a new modem and a NIC, and now I'm back online
 

ASK THE COMMUNITY