Question Ethernet Driver un-installable and stuck in 'Deep Sleep'

ReillyB

Reputable
Sep 22, 2016
2
0
4,510
0
I am running latest Windows 10 on an Asus P8P67 LE motherboard which has a Realtek 8111e Network Controller.
It started after I turned my computer on one morning, having apparently gone to sleep/shut off the night before on its own. I held the power button so if it was asleep it did not get a chance to wake up (Though sleep was set to never, I have still noticed my computer doing it on its own). Immediately, the ethernet was not working and so I followed the advice of a microsoft thread and tried to uninstall and reinstall the driver. Then the real trouble began with the Realtek installer failing due the following error: "The Realtek Network Controller was not found. If Deep Sleep Mode is enabled Please Plug the Cable."
Plugging in the cable had no effect.
Network reset had no effect.
Disabling, restarting and then enabling the Ethernet Controller in the Asus UEFI BIOS had no effect.
Leaving the RAM and CMOS out for at least a couple hours had no effect.

There was no ethernet controller detected in device manager, even with "Show hidden devices" (There was a "Microsoft Kernel Debug Network Adapter" but from what I seem to understand it's unrelated), nor anything in "Other devices". This prevented me from disabling "Allow the computer to turn off this device to save power" or manually installing the drivers. It was at this point I wiped the Windows drive, reinstalled a fresh copy of Windows 10 and unplugged all my other drives, still to no effect.
Installing all the latest motherboard drivers had no effect.
Trying older Realtek drivers had no effect.
Attempting in safe mode had no effect.
Attempting using Windows 7 compatibility mode had no effect.
Realtek's diagnostic utility program does not seem to detect it either.


So I am now stuck unable to detect any ethernet controller drivers or install new ones. Seems bricked as I have thoroughly exhausted my google-fu

In the interim I am (barely) managing with an ethernet-usb adapter but curiously it seems to sometimes be disappearing on startup like the Realtek driver (The increased frequency likely because the sleep settings defaulted with reinstall). This time rather rather than uninstall the driver I disabled "Allow the computer to turn off this device to save power" and the adapter works again. So it seems that is what happened to the Realtek driver until I made it worse by uninstalling as recommended. Additionally, it seems I still have not figured out how to disable the 'deep sleep' feature in my motherboard despite looking through all the BIOS menus (granted not all the terms were identifiable to me).
 
Last edited:

dazcan111

Distinguished
Nov 4, 2011
21
0
18,510
1
The latest version of windows made my Ethernet disappear, no fix as of yet and the gigabyte board is getting rma'd. I have tried everything,but it's gone.Nothing i have tried has found the Ethernet port. Gigabyte support couldn't help me after working the problem for 2 weeks. I get that kernel debug adapter under hidden devices,,removed that as well and no joy.Tried,all available bios for mine,windows 10 many times,windows 7...nothing,stuck on wifi. Goodluck
 

ASK THE COMMUNITY

TRENDING THREADS