Ethernet lights turn off once I get into Windows; can't update Realtek PCIE GBE family controller because code 31; etc


Aug 31, 2011
...; there is no local area connection in network adapter tab, realtek ethernet controller driver wont install because of deep sleep mode mode or something; in device manager, there is no network section, but at the bottom my realtek family controller is listed as unknown with a yellow exclamation point.

So many problems,yet after countless days, I cannot figure it out. I've tried everything I possibly could. The ethernet cable is fine because it works on my laptop and it lights up when i boot the PC, it just turns of the moment i enter windows. I cannot system restore because the restore point function was turned of for some reason -.-.. (turned it back on..).

I've always tried resetting cmos. The only thing I haven't done probably is update my bios. This is because apparently you need to have internet connection at all times during the update otherwise something will go wrong, but I have no internet at all so I cant do it.

I need help ASAP. I'm on my laptop right now and internet is fine through wifi..

I'm using Windows 7 64bit, Gigabyte GA H55M S2H (rev.1.1), 4 gig ram, r9 270x PCS+, i3 540 3.06 ghz, hx620w psu, Haf 912.

The problem started with me accidentally deleting the realtek PCIe familly controller driver from device manager. The moment I deleted it, i saw my internet go out from the red x on the bottom right of task bar. Since then I have not had internet on the computer..