Question Ethernet not detected by router all of a sudden?

puw2

Reputable
In the middle of a livestream my ethernet stopped working, infact my whole router only showed a red light. Rebooted it and WiFi works like charm but ethernet no longer works.

My PC's ethernet port has a blinking green light every 5(?)seconds or so but the ethernet symbol on the router no longer shows any color or indication that its doing anything.

I've reset my router, powered it off for 10mins, went to the setup page for my router and nothing.

When i go into the ethernet settings on my phone all it says is that "Ethernet cable not detected" (obviously..)

It already turned stopped working once today by all of a sudden only showing the red LED on the WiFi symbol but i got it fixed by rebooting the router, now its fixed in a sense that wifi works but ethernet doesnt.

Any help is appreciated!
 

kanewolf

Titan
Moderator
In the middle of a livestream my ethernet stopped working, infact my whole router only showed a red light. Rebooted it and WiFi works like charm but ethernet no longer works.

My PC's ethernet port has a blinking green light every 5(?)seconds or so but the ethernet symbol on the router no longer shows any color or indication that its doing anything.

I've reset my router, powered it off for 10mins, went to the setup page for my router and nothing.

When i go into the ethernet settings on my phone all it says is that "Ethernet cable not detected" (obviously..)

It already turned stopped working once today by all of a sudden only showing the red LED on the WiFi symbol but i got it fixed by rebooting the router, now its fixed in a sense that wifi works but ethernet doesnt.

Any help is appreciated!
Most likely a cable problem. You need to get a factory made cat5e or cat6a cable. Don't mess with cat7 or cat8 or flat cables. They are usually junk. Get a basic 100% copper round cable like this -- https://www.amazon.com/Monoprice-Flexboot-Cat5e-Ethernet-Patch/dp/B00KWS7GAC
 

puw2

Reputable
Most likely a cable problem. You need to get a factory made cat5e or cat6a cable. Don't mess with cat7 or cat8 or flat cables. They are usually junk. Get a basic 100% copper round cable like this -- https://www.amazon.com/Monoprice-Flexboot-Cat5e-Ethernet-Patch/dp/B00KWS7GAC
I will try and get a hold of another cable! My current one is cat6.

its just odd that the whole router essentially bricked and then after the reboot ethernet stopped working.. i'd think if the cable just broke it wouldnt interfene with my router to the point it shuts off..

But then again i dont specialize in networking at all so what do i know haha.

Thanks for the tip!
 

puw2

Reputable
Most likely a cable problem. You need to get a factory made cat5e or cat6a cable. Don't mess with cat7 or cat8 or flat cables. They are usually junk. Get a basic 100% copper round cable like this -- https://www.amazon.com/Monoprice-Flexboot-Cat5e-Ethernet-Patch/dp/B00KWS7GAC
Ok just got a new cable, i see that when i put the cable on my router the ethernet symbol blinks once like every 5-20seconds too.. Could the router be faulty? I have not found a single person so far with the same kind of problem.. Really got me scratching my head

EDIT: Wired connection with my phone works on PC, if thats anything noteworthy
 
Last edited:
If the pc works to the phone via ethernet then it has to be the router. Not sure how you manged a ethernet on a phone. Can you hook the phone to the router with the ethernet. If another device works to the router via ethernet then it is something more complex than just the router or pc.

It is very rare for a router lan ports to fail but it can happen. Although a risk that you may break it worse..ie can't get in via wifi..I would factory reset the router. You are very close to the point you have to buy a new router anyway.
 

puw2

Reputable
If the pc works to the phone via ethernet then it has to be the router. Not sure how you manged a ethernet on a phone. Can you hook the phone to the router with the ethernet. If another device works to the router via ethernet then it is something more complex than just the router or pc.

It is very rare for a router lan ports to fail but it can happen. Although a risk that you may break it worse..ie can't get in via wifi..I would factory reset the router. You are very close to the point you have to buy a new router anyway.
I woke up today and to my surprise the ethernet is now working as it should.. Very odd.

I just left it on yesterday and now it just works..
Could this have been a problem on my providers end? Or can they not intervene with my routers ethernet capabilities? Maybe its a sign of a dying router?

Either way, happy to have it back since my work depends on my ethernet connection since my pc doesnt have a WiFi card or built in wifi on my motherboard.
 
Hard to say could be some strange issue with the PC or router.

If it is your router the ISP has no access. I know of no router you can disable the ethernet ports. Most you can turn off the wifi but I have not seen one you can turn off ethernet.
 

ASK THE COMMUNITY