Ethernet problems [Help Meeeeeeee]

tehhijack

Honorable
Jan 7, 2013
42
0
10,530
Ok so i bought a dell inspiron 518 a few months back i used it to surf the web and watch videos do some gaming then it went into storage for 3 months i took it back out hooked it up and it didn't want to connect to the Internet, the cable is fine and the modem. i used the same cable for another pc and it worked i also connected the cable to a different spot on the router and it still worked but when i put my dell inspiron 518 on the Ethernet cable it wouldn't connect, it had a red X where the two little computers are on the task bar im on windows 7 ultimate 64 bit by the way, so i hit troubleshoot and it told me there was no network driver installed so i googled it and came up with a driver but it was only for windows vista i tried installing it with compatibility mode and it installed but i had no luck connecting to the Internet. I have a dell 0k068d motherboard in a dell inspiron 518 the Ethernet port is a Realtek – 10/100Mb/s im just frustrated i haven't been able to fix it for a few days can you guys help? here is the link for the motherboard
http://www.findlaptopdriver.com/specs-dell-0k068d/
 

tehhijack

Honorable
Jan 7, 2013
42
0
10,530
RealBeast the problem is i already tried that dident work also when i go into device manager there is no network adapter there ive searched every inch of dells website for drivers with no luck could my lan port have died? i dont see the green and orange lights flashing on the connector and i have windows 7 64 bit so i need a windows 7 64 bit driver
 

tehhijack

Honorable
Jan 7, 2013
42
0
10,530
Could the bios battery have anything to do with it?... I just checked battery is dead il switch it out and post an update. I checked the bios and lan is enabled but i dont understand how the bios battery could cause internet to fail i thought that battery was just for the clock haha.
 

tehhijack

Honorable
Jan 7, 2013
42
0
10,530
Well i could always buy a pci ethernet card and not risk bricking my motherboard again haha do you know of any way to do a backup of my bios incase something goes wrong?
 

tehhijack

Honorable
Jan 7, 2013
42
0
10,530
I don't know if it will fit my case i have a PNY GTX 550ti using up 2 of my slots one of the PCIe X1 slot is completely covered by the video card and the other one is extremely close to the fan i think it will not let the GTX 550 ti breathe i might just get a pci card but i dont know i might buy that one il post some pics later :(
 

tehhijack

Honorable
Jan 7, 2013
42
0
10,530
Also my original problem still persists :(

-[EDIT]- fixed my no audio problem i went into device manager and disabled hd audio device restarted pc and click volume icon in task bar it troubleshooted problems and it fixed it but my no Internet problem is still there [:russk1:9]
 

tehhijack

Honorable
Jan 7, 2013
42
0
10,530
No my card is still being delivered it will be here in a few days as for the lan yes it is enabled and i removed all drivers and reinstalled. Still no internet [:pdxalex]

-[EDIT]- When i go into device manager there is no networking icon so i cant try and install it from there and or disable and enable would you happen to have a fix for this? as far as i know when something breaks widows recognizes it as not working or malfunctioning it just wont flat out dissapear.
 

RealBeast

Titan
Moderator
There's no reason that your PCI slot shouldn't work, so I expect that the new card will fix the issue. That's the hard part about troubleshooting without a pile of parts in the closet, it takes longer. It's better now though -- when I started building computers in the 70's if you needed a driver, you had to call the company and have them mail it on a floppy disk. And then a week later find out that wasn't the issue. :)
 

tehhijack

Honorable
Jan 7, 2013
42
0
10,530
Ok RealBeast it is out for delivery it will be here in the next few hours il get back to you once i install and i confirm it working either way you will hear from me if it works or if it doesent