Question ethernet switch strange problem

Jul 4, 2022
2
0
10
0
charter/spectrum internet and modem, tp link4000 router. for over a year i used a Ethernet switch , it was a d link des 1024d, it suddenly stopped sending data to ever port, so i assumed it was dead, i bought a d link dss16+, everything worked good for about two months, then it did the same thing, the lights flash as if it is sending data out same as the des 1024d did, so i had two small cheaper ethernet switchs a small brash 5 port and a a netgear gs605 5 port, if i hook these two up the ethernet works, i have got three more switches, they will not send data out on all ports, only the two junk small switches will. do i have a router problem ? all these are non manged switches. any help would be greatly appreciated.
 
Unmanged switch pretty much work or they don't. There tends to be nothing you can set or configure. Maybe it has a reset button but since these device are 100% hardware you can't even do stuff like change firmware.

So what happens if you plug the small switch into the router. Then plug the "broken" switch into the small switch and then plug your pc into another port on the broken switch.

Maybe it is just something strange that the ports are not negotiating the correct speed with your router. The 2 switches you are having issues with are only 10/100 where almost all modern equipment is gigabit. It is suppose to all work together but years ago there where issues.

Just guessing though. In the end a unmanaged switch is going to work or it is not. It is possible to damage them, I had a lightning strike near my house that damaged stuff even though I have ups and surge protectors on every device. It would be unlikely you lose 2 the same way.
 

ASK THE COMMUNITY

TRENDING THREADS