Question Event 4101. Why?

Dec 7, 2022
3
0
10
0
Error:

The description for Event ID 0 from source nvlddmkm cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.

If the event originated on another computer, the display information had to be saved with the event.

The following information was included with the event:

\Device\Video3
Error occurred on GPUID: 800

The message resource is present but the message was not found in the message table


Followed by Warning:

Event 4101: Display driver nvlddmkm stopped responding and has successfully recovered.



Specs:
CPU – AMD Ryzen 9 3900x
Motherboard – TUF gaming x570-plus (wifi)
GPU – MSI geforce rtx2080 super gaming x trio
Cooling – Corsair H150i pro
SSD – Samsung 860 evo
PSU – Corsair RM750
RAM – Corsair vengeance rgb pro 2×16GB 3200MHz



I bought and built this PC in June 2020, using it primarily for gaming, and until recently have had no issues with it. About a month ago I began to get the error and warning codes as seen above. As far as I am aware there were no updates immediately preceding this, nor any setting changes that I am aware of. The PC could handle low intensity games, although simply scrolling up and down on a high-graphical page such as the Steam store would cause the screen to briefly black out with the same error messages in the event viewer, and attempting to play a demanding game would result in a game crash (not complete PC crash) with the same error messages. Attempting to watch shows on amazon prime also resulted in these errors.

Worth noting hardware scheduling and the DOCP profile were by default turned off, and had been so since buying the PC. I have not overclocked any of the components outside of changing power plan via MSI dragon center.

Since then I have:
-Cleanly reinstalled graphics drivers using DDU
-Ran Furmark with no issues
-Used an alternative graphics card with the same result
-Reinstalled OS

After the above I decided to test each stick of RAM individually, and found that the PC wouldn’t even start with one of the sticks – the motherboard displaying an LED warning signaling DRAM fault. After removing the faulty stick – and at this point I turned on hardware scheduling and the DOCP profile – my issue seemed to be resolved and it was able to return to normal functionality. I then ordered replacement RAM sticks.

After installing the new RAM sticks and setting the DOCP profile to 3466MHz (maximum applicable setting for the new sticks with my processor and motherboard), I managed a day of normal use before the issue returned in full. And this is where my already minimal comprehension of this situation really disappears.

I tried both the new RAM sticks individually, thinking that perhaps the second DIMM slot might be defective and could have somehow damaged the original stick inserted. This time however regardless of which stick was inserted the problem persisted. After turning the DOCP profile back down to 3200MHz, and only having one stick of RAM inserted, the PC returned to normal functionality.

I then updated the bios, and after this I was able to set the DOCP back to 3466MHz and game without issue (with only the one stick of RAM installed). I updated the chipset drivers and reinstalled a second stick of RAM only to have the error return. I removed the second stick of RAM and functionality was again restored, although the following day I noticed an FPS drop and stuttering with certain games.

Based on this I again thought that perhaps the second DIMM slot might be defective, except for the issue being briefly present even when only one stick was inserted (in the correct slot).

I have ran a stress test on my CPU with nothing out of the ordinary, and have run a full diagnostic scan on my SSD with no red flags. My temperatures have been behaving normally as far as I can tell.

I have also tried running games with debug mode turned on in nvidia control panel, as well as turning off simultaneous multithreading in ryzen master, both to no effect.

I have been unable to run tests on the PSU, and have not been able to determine if there is a fault with the motherboard itself. Since I was going to have to upgrade my PSU to an 850 at some point anyway, I think my plan is to get a new motherboard as well and just hope for the best.

Before that however, if anyone has any idea of what the hell is going on, I would greatly appreciate any info.

Cheers
 

Lutfij

Titan
Moderator
Welcome to the forums, newcomer!

RAM – Corsair vengeance rgb pro 2×16GB 3200MHz
I'm missing something perhaps, the ram you have are advertised to go to DDR4-3200MHz, how are you going to DDR4-3466MHz? What other parameters of the ram kit did you change to get to those speeds?

Reinstalled OS
What OS are you working with?

I then updated the bios
For the sake of relevance, what BIOS version are you currently on for your motherboard?

Might want to take your ram kit and processor over onto a donor system(friend's or neighbors) and see if you get a similar issue crop up.
 
Dec 7, 2022
3
0
10
0
Thanks for the reply,
Sorry forgot to mention the replacement ram sticks I ordered were 3600MHz. Set to 3466 in the bios.
OS windows 10.
I'll have to check bios version tomorrow, although I also forgot to mention I rolled it back a version and still had the same issue.
I'll ask my friends if they would be willing to test my components.
 

ASK THE COMMUNITY