Question Evil Within 2 Launches to Black Screen with Sound

Jul 27, 2020
3
0
10
0
First time poster - sorry in advance for anything silly I say.

My problem: The Evil Within 2 launches to a black screen, but I can hear all the game sounds (logos, menu). When I use Alt+Enter to switch between windowed and full screen, I see brief flashes of the menu, but can't get those to stabilise. I've seen people post about this on Steam forums, but no one had a reliable fix. A couple here had this issue with Evil Within 1, but this person seems to have fixed the issue by reinstalling (didn't work for me), while this person only had integrated graphics and just couldn't run the game.

My specs:
NVIDIA GeForce GTX 1050 Ti 4GB
Laptop - ACER Aspire VX5
Windows 10 64-bit
Intel Core i7 7700HQ @ 2.80GHz
16 GB RAM
Monitor - inbuilt, 1920x1080, 32BPP, 60Hz
Game run via Steam
The usual "I've been able to play more recent games than EW2 without issues" disclaimer

Here's what I've tried so far:
  • Reinstall
  • Verify game files (Steam)
  • Update GPU drivers
  • Made sure game is running on right GPU, not integrated graphics
  • Run as admin
  • Run in compatibility mode
  • Disabled full-screen optimisation
  • Selected option to override high DPI scaling behaviour
  • Run windowed
  • Looked for a config file in the game folder that I could change or delete - there doesn't seem to be one (hidden files shown)
  • Disable GeForce experience, battery boost, overlay
This is pretty much the outer limit of my computer skills - I don't really want to mess around with anything to 'deep' inside the computer (BIOS or stuff like that) just to run a game. I can live without it. I just feel like I'm really close and there might be some silly solution somewhere... The game runs, I just can't see it, so surely it should be playable.. right?

Sorry for massive post. Any help would be hugely appreciated.
 
Your hardware is good enough to run the game, but nowhere near recommended spec where it counts most (GPU), so you need to temper settings due to that. Other than that, since you said you tried compat mode, I'm not sure what OS you're running, which may be the culprit, depending on what OS features are enabled. If on W10, try disabling Game Bar. Also disable any unnecessary back ground programs (startups), just to eliminate the possibility of conflicts.

I would also advise running an SFC scan, and restore the system image file first. exactly as it shows here.
https://support.microsoft.com/en-us/help/4026529/windows-10-using-system-file-checker
 
Jul 27, 2020
3
0
10
0
Thanks for taking the time to respond, appreciate it!

I'm running Windows 10 64-bit. I've now disabled the game bar - good to have that off in general - and turned off the rest of my startup apps. The SFC scan didn't turn up any integrity issues.

Really not sure what else this could be; might just have to wait to play the game after I've upgraded my hardware at some point...
 
Jul 27, 2020
3
0
10
0
Are you using moderate graphics settings in game? If so, there's no reason that spec shouldn't run it.
Yeah - I've tried with moderate and low settings (right down to lowest possible), at different resolutions (I can't actually see the settings menu in game itself, but have been able to adjust them through GeForce).
 

ASK THE COMMUNITY

TRENDING THREADS