Experiencing flickering in Far Cry 5

Oct 3, 2018
4
0
10
0
Hello i have a problem i hope you guys can help me with. i recently finished building my pc.
Here is a look at the setup i got https://pcpartpicker.com/list/z6LRq4 .
So after i finished i got into playing a lot of far cry 5 doing quests main story and all that stuff (takes some time) and some multiplayer battlefield 1 on the side. After building my awesome rig i wanted to test it so im playing all my games at the highest settings including farcry. And after a while while exploring inside i noticed texture flickering. As you can see here https://youtu.be/wggy6Joefwc (it happened multiple times this is just an example, and although it doesnt happen that often it still bugs me when it does.) . Note that as far as i know i didnt experience this in battlefield 1 and i didnt have much time to delve into other games as deep as to notice this kinds of issues. So my question is? is my gpu faulty, is the game having issues with my 1440p 21:9 monitor or maybe the fact that i run a second 1080p? i run the game at max settings and fullscreen (not windowed not borderless). Is this a software compatibility or is my hardware faulty. If so i need to know which parts i need to return. Hope to hear from you. Thank you in advance.
 

QwerkyPengwen

Dignified
Herald
not likely that the settings are too high for your hardware to handle properly.
I have a 1070 and run farcry 5 at max settings without this flickering issue.

Are you overclocking your CPU and/or GPU?
If so, your one or both of your overclocks might not be stable.

For your second display, are you plugged directly into the GPU? If so, perhaps try making sure that iGPU is enabled in BIOS and plugging it into the motherboard output instead, making the CPU's onboard graphics handle it instead of your GPU.
 
Oct 3, 2018
4
0
10
0

Thank you for your response. Overclock wise. I let my cpu run somewhere between 4.2ghz to 4.8ghz the motherboard does its adaptive thing with it. The gpu is only overclocked by the new tool that comes with the new 2000 series gpu the nvidia tuning tool. I see it reaching most of the time a max of 1930hz on the gpu. I dont think the overclocks are too over the top. I will try plugging the second monitor i am not usually gaming on into the motherboard. Ill test some more and ill come back to you. But my main problem that i need a fast answer for ïs : could this be faulty hardware? cuz if it is i need to know what to return.
 
Oct 3, 2018
4
0
10
0
Coming back with more information. I removed the second display out of the equation completely and i under clocked the gpu as much as msi afterburner lets me (-502) and i set all the graphic settings at low and i still have the issues. Here you can see the result. https://youtu.be/1lRjGvT39R4
Also i took a little bit of time and tried to reproduce the error in more games (battlefield 1, PUBG, just cause3, the witcher 3 and rainbow 6 siege) and i couldnt. So as far as i know only far cry 5 does this
 
Oct 6, 2018
1
0
10
0
Joining in here since I also have this issue.

I tried swapping my GTX 1080 with my GTX 970. That removed the flickering. I tried the game for 30minutes without reproducing the flickering. I Tried both games on the same game settings. Plugged back my 1080 and the flickering was back.

I have also tried with every different sync option. Vsync, Fast sync and Adaptive sync.

Does this mean i have a faulty card?

I have also defaulted all OC on GPU, CPU and ram.

This is what it looks like on my system.
https://www.youtube.com/watch?v=khmQpG6xsQY
GTX 1080
I5 8600k
Msi Pro carbon Z370
750w XFX Pro
Gaming at 60hz 1080p
 

QwerkyPengwen

Dignified
Herald
Try this. I've looked around since I never had this issue and found a possible solution.

If you are running the game in full screen mode, then switching to borderless window mode should fix the issue.

If it turns out that full screen mode is the culprit, and you really want full screen mode for whatever reason, then you can try fiddling with options like disabling full screen optimization in the properties of the executable for the game and/or by messing with some certain things in nvidia control panel.

Also, just as a general rule for performance optimization, disabling the uplay overlay in the uplay program can give you some slight improvements to framerates or possible framerate stutters.

For some people, turning off shadowplay can help too if you're running an nvidia card (although I haven't seen issues with this since an update they did a long time ago that fixed problems like this)

Lastly, if you happen to be running windows 10 and happen to be one of those people that went through certain steps to disable game mode in windows 10 by adding a line in the registry then I recommend deleting that and letting game mode be active like it's supposed to, since it doesn't cause performance issues like it used to and disabling it can actually cause you to have worse performance than if you leave it alone.
 

dudio

Admirable
You haven't mentioned any system temps (tho I doubt that's the problem), they're always cool (no pun intended) to look at.
I would look at capping you refresh rate of the monitor and fps to match, and see what that does
 
Oct 3, 2018
4
0
10
0



Full screen mode is not the problem i tried running windowed and still the issue appears. The temps never exceeded 70 C the drivers i think are the problem since a lot of people have been experiencing this in recent times. Here i found some more people that have been experiencing this problem:
https://forums.ubi.com/showthread.php/1936324-Strange-jittery-shadow-glitch-on-latest-Nvidia-hardware-amp-drivers
Also i managed to recreate the issue in the witcher 3
https://www.youtube.com/watch?v=R_6arXEAw7s&feature=youtu.be
https://www.youtube.com/watch?v=JTt7ZXu8y64&feature=youtu.be
 

ASK THE COMMUNITY

TRENDING THREADS