[SOLVED] External hard disk not getting powered on


Sep 28, 2018
So I have a 2TB Seagate external hard drive. Was copying some files on the disk and deleted a couple of unwanted folders. When I opened up a new folder, the disk froze and after sometime it crashed and the power light switched off. Thought the disk was dead but nevertheless opened disk management and it is showing up there. The whole 1860GB is being displayed as unallocated and under the disk number, it says not initialized.

Checked a few videos on youtube and first I tried to create a new partition but the "New Simple Volume" option is greyed out. Another solution that I saw said I should convert MBR to GPT but none of the available software that I found allow that in the free version. Then I tried initializing the disk but got a cyclic redundancy check data error regardless of whether I used MBR or GPT. To fix this error, I was told to go in the command prompt and use chkdsk but when I did that, I get an error message saying "cannot open volume for direct access"

Is there a way to revive the drive? Dont really care about the data as I have two other backups and I dont really want to throw this drive away. But if I can reset the drive without losing the data then it would be an added bonus.