External hard disk safely remove problem

TimesTwo

Distinguished
Mar 3, 2009
14
0
18,510
i am using an external hard disk on vista64 in a Vantec enclosure and whenever i safely remove it, the computer will say it is safe to remove but then the hard disk keeps on running..... but when i use it on the other computer that runs windows xp and i safely remove it, the hard disk stops on running..... can anyone tell why vista is acting like that....

thanks
 
All my enclosures have a power switch to shut down the unit, when I finish with transferring data and get Vistas OK I turn off the unit, the Vantec Enclosure doesn't have a power switch?

If the unit is powered by the computer, You can always unplug the USB cable thats what the safely remove feature is for anyway.
 

TimesTwo

Distinguished
Mar 3, 2009
14
0
18,510
Yes it has a power switch. but my concern is when i safely remove it, vista will say it is safe to remove BUT when i touch the hard disk, it's still running.... when i plug it into my windows xp and i safely remove it, the hard disk stops on working/running... why is it acting like that on vista?
 

wdfdo1986

Distinguished
Jul 20, 2009
1
0
18,510
I have the same problem. When the hard disk removed also its working
And turning off directly isnt a good way cause it is not good for the hard disk.
If some one know the way pls post it here.
 

soundefx

Distinguished
Jan 17, 2008
661
0
19,010
It is a small difference between how vista and xp works.

If a usb flash drive with a on light indicator is placed in a xp computer and is 'ready to be ejected', you will notice that the light is turned off. XP actually stops all power and data transfer to the usb device.

Vista does not do this, therefore you will notice that there is still hard drive activity, but it should be safe to unplugged it from the computer.
After that, the hard drive should stop and then you could use the power switch and power off the external hard drive.
 

stef2503

Distinguished
Jan 3, 2009
4
0
18,510
I have the same problem and I can tell you I don't feel it's safe to use my hard drive with Vista because I can hear the heads scratching the disk whenever I unplug the USB cable. And that happens every time, no matter how long I wait after the OS tells me it's safe to remove it. XP seems to do a totally different job as it's not just turning the power off, but also parking the heads where they should be. Shutting down the computer isn't a solution either, as it basically cuts the power from the USB ports and the heads hit again the disk's surface. I haven't found any solution to this issue yet, but I will keep researching on it. I'll keep in touch if I find something useful.
 
G

Guest

Guest
I had the same problem. It's usually a piece of software accessing the drive still. Try this program out.

http://en.kioskea.net/telecharger/telecharger-2586-unlocker

Its called unlocker and it will add an option to your right click when you right click any device or file and tell you which processes are accessing it and will enable you to stop those processes so you can properly run the "Safely Remove USB storage device" utility under windows. It will even tell you how to create a bat file to automate it for say a drive everytime.
 

ravisghosh

Distinguished
Jul 29, 2011
12
0
18,510
I got an esatap enclosure which does not have any switch. When I put in Linux, I have the option of unmounting it, but the heads still keep on scratching the hd. On Windows Vista, I don't get an option to safely remove at all. It simply shows as an internal disk.
 

Anzar

Distinguished
Nov 16, 2011
10
0
18,520
I have a problem that when I eject My External Harddisk in win7 shows safely remove but light doesn't turn Off Harddisk spins but in other OS it is proper. So can you tell me what to do To eject properly in win7?
 

anoopmv3

Distinguished
Jan 31, 2012
1
0
18,510
Hi, does anyone encounter this issue with win 7 too?

Hi Anonymous,

I too had this issue in Win7, Im having seagate go flex hardisk 500Gb after safe removal also, the hardisk keeps on running...

After lots of searching now the issue is solved :) simply install this software..
http://safelyremove.com/download.htm

During installation Win7 will ask whther to enable power off mode after saferemoval... just accept that... then everything will be fine...