External HD not showing up - not initialized?


May 29, 2012
I know there's been a lot of threads about this topic but none have them have solved my issue. I have a 500gb WD Scorpio blue hard drive in an external case. It's my old hard drive from my last computer - I've got tons of music on it and more importantly a lot of projects and work that I was working on. Last laptop was Gateway Win 7 intel pc. I'm now using a toshiba AMD Win 7 pc.

When I plug it into the USB port (I tried all of them) I get the little icon that appears in the lower right corner showing that I have a usb device plugged in, I get the little chime that comes with it too. What doesnt happen is the hard drive showing up in My Computer. It shows up in My Devices as a USB mass storage device.

Someone posted this.....

"Assuming that the drive has been properly partitioned and formatted, then this USB drive probably still needs to be enumerated for this computer. Open Control Panel. Go through Administrative Tools to Computer Management. Under Storage, click on Disk Management. Locate the USB drive and it
probably needs to have a drive letter assigned to it. Do so (Right click and change drive letter - make sure it's not in use at time). Should take care of the problem."

The drive shows up there as "Disk 1 - unknown. Not initialized". A box usually pops up asking me if I want to initialize the disk. I click ok and get a pop up that says " data error (cyclic redundancy check)".

Any ideas where to go from here? The drive powers up and sounds great - no funny noises. All my friends have Macs and the drive doesnt work on any of their computers.