External HDD can't be stopped?

Kenny

Distinguished
Feb 9, 2001
379
0
18,780
Archived from groups: microsoft.public.windowsxp.basics (More info?)

Have added an IcyBox external HDD enclosure with a 160GB Maxtor drive in it.
Works OK but when I try to stop it get the message.

"Problem ejecting USB mass storage device.
The device 'Generic volume' cannot be stopped right now. Try stopping the
device again later."

No problem with other external USB devices.
Doesn't work even after fresh reboot. I sometimes see the HDD activity light
on even though I'm not using the HDD. Maybe related is the fact that
occasionally PC sticks at "Shutting down Windows" and I have to use the
power switch. This was happening before adding the new HDD.
Using XP Pro with SP1, updated chipset drivers and recent BIOS flash on Asus
A7N8X m/b with Athlon XP 2500 & 512MB RAM.

--

Kenny
 
G

Guest

Guest
Archived from groups: microsoft.public.windowsxp.basics (More info?)

If it behaves this way when attached to another computer, it might be a
defect in the hard drive controler or a cable or connection inside the
enclosure. Have you gone to the manufacturer's website for diagnostic and
support options?

"Kenny" <me@privacy.net> wrote in message
news:ev5ZGGQsEHA.3076@TK2MSFTNGP09.phx.gbl...
> Have added an IcyBox external HDD enclosure with a 160GB Maxtor drive in
> it.
> Works OK but when I try to stop it get the message.
>
> "Problem ejecting USB mass storage device.
> The device 'Generic volume' cannot be stopped right now. Try stopping the
> device again later."
>
> No problem with other external USB devices.
> Doesn't work even after fresh reboot. I sometimes see the HDD activity
> light
> on even though I'm not using the HDD. Maybe related is the fact that
> occasionally PC sticks at "Shutting down Windows" and I have to use the
> power switch. This was happening before adding the new HDD.
> Using XP Pro with SP1, updated chipset drivers and recent BIOS flash on
> Asus
> A7N8X m/b with Athlon XP 2500 & 512MB RAM.
>
> --
>
> Kenny
>
>
>
 
G

Guest

Guest
Archived from groups: microsoft.public.windowsxp.basics (More info?)

Hi Kenny,

I occasionally get the same notification when i disconnect
my external USB card reader, but it's always ok if you
click OK, then disconnect a second time.
Obviously if the HHD is being accessed for any reason when
you try to disconnect, you'll always get the warning.

As for activity whilst not even using it, there are 2 possibilities
that come to my mind, depending upon your set-up.
One of them is cidaemon.exe, and runs in the background,
as a Windows indexing service and catalogues files on your
computer to enable faster file searches.

The second possibility is, if you are using Norton Anti-virus,
one of its default settings is to constantly monitor external
storage devices, and is generally reviewed as best turned off,
(the option that is, not NAV).

Have a look and come back with any findings
John



"Kenny" <me@privacy.net> wrote in message news:ev5ZGGQsEHA.3076@TK2MSFTNGP09.phx.gbl...
> Have added an IcyBox external HDD enclosure with a 160GB Maxtor drive in it.
> Works OK but when I try to stop it get the message.
>
> "Problem ejecting USB mass storage device.
> The device 'Generic volume' cannot be stopped right now. Try stopping the
> device again later."
>
> No problem with other external USB devices.
> Doesn't work even after fresh reboot. I sometimes see the HDD activity light
> on even though I'm not using the HDD. Maybe related is the fact that
> occasionally PC sticks at "Shutting down Windows" and I have to use the
> power switch. This was happening before adding the new HDD.
> Using XP Pro with SP1, updated chipset drivers and recent BIOS flash on Asus
> A7N8X m/b with Athlon XP 2500 & 512MB RAM.
>
> --
>
> Kenny
>
>
>
 

Kenny

Distinguished
Feb 9, 2001
379
0
18,780
Archived from groups: microsoft.public.windowsxp.basics (More info?)

Thanks for the reply. I have turned off Indexing Service but no difference.
I do have NAV 2003 but couldn't find the "constantly monitor external
storage" to turn it off.
In USB Device Properties for the drive I found the option to disable or
enable write caching. It was set by default to "optimise for quick removal"
and tells me that using this option I can disconnect without using Safe
Removal icon. I had always believed you couldn't do this, it can cause data
loss, and haven't tried it.
Tried enabling this option but still no difference.

--

Kenny


"John Mc" <john@mccabe2001.(no_spam).freeserve.com> wrote in message
news:uRv8$YVsEHA.2808@TK2MSFTNGP14.phx.gbl...
> Hi Kenny,
>
> I occasionally get the same notification when i disconnect
> my external USB card reader, but it's always ok if you
> click OK, then disconnect a second time.
> Obviously if the HHD is being accessed for any reason when
> you try to disconnect, you'll always get the warning.
>
> As for activity whilst not even using it, there are 2 possibilities
> that come to my mind, depending upon your set-up.
> One of them is cidaemon.exe, and runs in the background,
> as a Windows indexing service and catalogues files on your
> computer to enable faster file searches.
>
> The second possibility is, if you are using Norton Anti-virus,
> one of its default settings is to constantly monitor external
> storage devices, and is generally reviewed as best turned off,
> (the option that is, not NAV).
>
> Have a look and come back with any findings
> John
>
>
>
> "Kenny" <me@privacy.net> wrote in message
news:ev5ZGGQsEHA.3076@TK2MSFTNGP09.phx.gbl...
> > Have added an IcyBox external HDD enclosure with a 160GB Maxtor drive in
it.
> > Works OK but when I try to stop it get the message.
> >
> > "Problem ejecting USB mass storage device.
> > The device 'Generic volume' cannot be stopped right now. Try stopping
the
> > device again later."
> >
> > No problem with other external USB devices.
> > Doesn't work even after fresh reboot. I sometimes see the HDD activity
light
> > on even though I'm not using the HDD. Maybe related is the fact that
> > occasionally PC sticks at "Shutting down Windows" and I have to use the
> > power switch. This was happening before adding the new HDD.
> > Using XP Pro with SP1, updated chipset drivers and recent BIOS flash on
Asus
> > A7N8X m/b with Athlon XP 2500 & 512MB RAM.
> >
> > --
> >
> > Kenny
> >
> >
> >
>
>
 
G

Guest

Guest
Archived from groups: microsoft.public.windowsxp.basics (More info?)

Hot unplugging as you mention is possible if you have set it for
"quick removal", but i would still only suggest it while the drive
is not being accessed, obviously if it is being written to
then the data will be lost, so choose your disconnection
time carefully.

In NAV 2003, i think the option is in ...
Options|Anti Virus|Auto Protect|Advanced|Scan removable media...
It was only a suggestion that was made to me a year or so ago,
when i noticed my processor was being used heavily and
writing to my USB2 HHD.



"Kenny" <me@privacy.net> wrote in message news:eWfMJ0WsEHA.3336@tk2msftngp13.phx.gbl...
> Thanks for the reply. I have turned off Indexing Service but no difference.
> I do have NAV 2003 but couldn't find the "constantly monitor external
> storage" to turn it off.
> In USB Device Properties for the drive I found the option to disable or
> enable write caching. It was set by default to "optimise for quick removal"
> and tells me that using this option I can disconnect without using Safe
> Removal icon. I had always believed you couldn't do this, it can cause data
> loss, and haven't tried it.
> Tried enabling this option but still no difference.
>
> --
>
> Kenny
>
>
> "John Mc" <john@mccabe2001.(no_spam).freeserve.com> wrote in message
> news:uRv8$YVsEHA.2808@TK2MSFTNGP14.phx.gbl...
> > Hi Kenny,
> >
> > I occasionally get the same notification when i disconnect
> > my external USB card reader, but it's always ok if you
> > click OK, then disconnect a second time.
> > Obviously if the HHD is being accessed for any reason when
> > you try to disconnect, you'll always get the warning.
> >
> > As for activity whilst not even using it, there are 2 possibilities
> > that come to my mind, depending upon your set-up.
> > One of them is cidaemon.exe, and runs in the background,
> > as a Windows indexing service and catalogues files on your
> > computer to enable faster file searches.
> >
> > The second possibility is, if you are using Norton Anti-virus,
> > one of its default settings is to constantly monitor external
> > storage devices, and is generally reviewed as best turned off,
> > (the option that is, not NAV).
> >
> > Have a look and come back with any findings
> > John
> >
> >
> >
> > "Kenny" <me@privacy.net> wrote in message
> news:ev5ZGGQsEHA.3076@TK2MSFTNGP09.phx.gbl...
> > > Have added an IcyBox external HDD enclosure with a 160GB Maxtor drive in
> it.
> > > Works OK but when I try to stop it get the message.
> > >
> > > "Problem ejecting USB mass storage device.
> > > The device 'Generic volume' cannot be stopped right now. Try stopping
> the
> > > device again later."
> > >
> > > No problem with other external USB devices.
> > > Doesn't work even after fresh reboot. I sometimes see the HDD activity
> light
> > > on even though I'm not using the HDD. Maybe related is the fact that
> > > occasionally PC sticks at "Shutting down Windows" and I have to use the
> > > power switch. This was happening before adding the new HDD.
> > > Using XP Pro with SP1, updated chipset drivers and recent BIOS flash on
> Asus
> > > A7N8X m/b with Athlon XP 2500 & 512MB RAM.
> > >
> > > --
> > >
> > > Kenny
> > >
> > >
> > >
> >
> >
>
>
 

Kenny

Distinguished
Feb 9, 2001
379
0
18,780
Archived from groups: microsoft.public.windowsxp.basics (More info?)

Have solved the problem. PC has 6 USB ports, 4 at back and 2 at front. I
had been using one of the front ports and decided to try it at the back.
Safe Removal option now works. I don't know why it works, the 2 front USB's
are connected via header pins on m/b whilst the back USB's are integral to
the m/b.

--

Kenny


"Colin Barnhorst" <colinbarharst@msn.com> wrote in message
news:OAybCLXsEHA.3200@TK2MSFTNGP09.phx.gbl...
> If it behaves this way when attached to another computer, it might be a
> defect in the hard drive controler or a cable or connection inside the
> enclosure. Have you gone to the manufacturer's website for diagnostic and
> support options?
>
> "Kenny" <me@privacy.net> wrote in message
> news:ev5ZGGQsEHA.3076@TK2MSFTNGP09.phx.gbl...
> > Have added an IcyBox external HDD enclosure with a 160GB Maxtor drive in
> > it.
> > Works OK but when I try to stop it get the message.
> >
> > "Problem ejecting USB mass storage device.
> > The device 'Generic volume' cannot be stopped right now. Try stopping
the
> > device again later."
> >
> > No problem with other external USB devices.
> > Doesn't work even after fresh reboot. I sometimes see the HDD activity
> > light
> > on even though I'm not using the HDD. Maybe related is the fact that
> > occasionally PC sticks at "Shutting down Windows" and I have to use the
> > power switch. This was happening before adding the new HDD.
> > Using XP Pro with SP1, updated chipset drivers and recent BIOS flash on
> > Asus
> > A7N8X m/b with Athlon XP 2500 & 512MB RAM.
> >
> > --
> >
> > Kenny
> >
> >
> >
>
>
 
G

Guest

Guest
Archived from groups: microsoft.public.windowsxp.basics (More info?)

While I don't doubt you, it seems odd as it seems your problem is a
hardware problem, i.e. related to the motherboard. That doesn't seem
reasonable but who knows. I use a Gigabyte board and my USB-HDD connects to
the front ports. I have no problems stopping the drive before disconnecting
so your solution appears to be either machine or board specific.

"Kenny" <me@privacy.net> wrote in message
news:OYUoa1csEHA.3508@TK2MSFTNGP14.phx.gbl...
> Have solved the problem. PC has 6 USB ports, 4 at back and 2 at front. I
> had been using one of the front ports and decided to try it at the back.
> Safe Removal option now works. I don't know why it works, the 2 front
> USB's
> are connected via header pins on m/b whilst the back USB's are integral to
> the m/b.
>
> --
>
> Kenny
>
>
> "Colin Barnhorst" <colinbarharst@msn.com> wrote in message
> news:OAybCLXsEHA.3200@TK2MSFTNGP09.phx.gbl...
>> If it behaves this way when attached to another computer, it might be a
>> defect in the hard drive controler or a cable or connection inside the
>> enclosure. Have you gone to the manufacturer's website for diagnostic
>> and
>> support options?
>>
>> "Kenny" <me@privacy.net> wrote in message
>> news:ev5ZGGQsEHA.3076@TK2MSFTNGP09.phx.gbl...
>> > Have added an IcyBox external HDD enclosure with a 160GB Maxtor drive
>> > in
>> > it.
>> > Works OK but when I try to stop it get the message.
>> >
>> > "Problem ejecting USB mass storage device.
>> > The device 'Generic volume' cannot be stopped right now. Try stopping
> the
>> > device again later."
>> >
>> > No problem with other external USB devices.
>> > Doesn't work even after fresh reboot. I sometimes see the HDD activity
>> > light
>> > on even though I'm not using the HDD. Maybe related is the fact that
>> > occasionally PC sticks at "Shutting down Windows" and I have to use the
>> > power switch. This was happening before adding the new HDD.
>> > Using XP Pro with SP1, updated chipset drivers and recent BIOS flash on
>> > Asus
>> > A7N8X m/b with Athlon XP 2500 & 512MB RAM.
>> >
>> > --
>> >
>> > Kenny
>> >
>> >
>> >
>>
>>
>
>
 
G

Guest

Guest
Archived from groups: microsoft.public.windowsxp.basics (More info?)

Bizarre. I've had the same problem. I only have two USB ports on my laptop,
and, after reading this thread, swapped my printer and external HDD. Not
only can I now safely remove the HDD, the icon gives it a different name!
Whatever works, I guess...

"Edward W. Thompson" wrote:

> While I don't doubt you, it seems odd as it seems your problem is a
> hardware problem, i.e. related to the motherboard. That doesn't seem
> reasonable but who knows. I use a Gigabyte board and my USB-HDD connects to
> the front ports. I have no problems stopping the drive before disconnecting
> so your solution appears to be either machine or board specific.
>
> "Kenny" <me@privacy.net> wrote in message
> news:OYUoa1csEHA.3508@TK2MSFTNGP14.phx.gbl...
> > Have solved the problem. PC has 6 USB ports, 4 at back and 2 at front. I
> > had been using one of the front ports and decided to try it at the back.
> > Safe Removal option now works. I don't know why it works, the 2 front
> > USB's
> > are connected via header pins on m/b whilst the back USB's are integral to
> > the m/b.
> >
> > --
> >
> > Kenny
> >
> >
> > "Colin Barnhorst" <colinbarharst@msn.com> wrote in message
> > news:OAybCLXsEHA.3200@TK2MSFTNGP09.phx.gbl...
> >> If it behaves this way when attached to another computer, it might be a
> >> defect in the hard drive controler or a cable or connection inside the
> >> enclosure. Have you gone to the manufacturer's website for diagnostic
> >> and
> >> support options?
> >>
> >> "Kenny" <me@privacy.net> wrote in message
> >> news:ev5ZGGQsEHA.3076@TK2MSFTNGP09.phx.gbl...
> >> > Have added an IcyBox external HDD enclosure with a 160GB Maxtor drive
> >> > in
> >> > it.
> >> > Works OK but when I try to stop it get the message.
> >> >
> >> > "Problem ejecting USB mass storage device.
> >> > The device 'Generic volume' cannot be stopped right now. Try stopping
> > the
> >> > device again later."
> >> >
> >> > No problem with other external USB devices.
> >> > Doesn't work even after fresh reboot. I sometimes see the HDD activity
> >> > light
> >> > on even though I'm not using the HDD. Maybe related is the fact that
> >> > occasionally PC sticks at "Shutting down Windows" and I have to use the
> >> > power switch. This was happening before adding the new HDD.
> >> > Using XP Pro with SP1, updated chipset drivers and recent BIOS flash on
> >> > Asus
> >> > A7N8X m/b with Athlon XP 2500 & 512MB RAM.
> >> >
> >> > --
> >> >
> >> > Kenny
> >> >
> >> >
> >> >
> >>
> >>
> >
> >
>
>
>
 
G

Guest

Guest
Archived from groups: microsoft.public.windowsxp.basics (More info?)

oops - my mistake about the icon renaming the drive - careless error. But I
can still safely remove it!

"operaflute" wrote:

> Bizarre. I've had the same problem. I only have two USB ports on my laptop,
> and, after reading this thread, swapped my printer and external HDD. Not
> only can I now safely remove the HDD, the icon gives it a different name!
> Whatever works, I guess...
>
> "Edward W. Thompson" wrote:
>
> > While I don't doubt you, it seems odd as it seems your problem is a
> > hardware problem, i.e. related to the motherboard. That doesn't seem
> > reasonable but who knows. I use a Gigabyte board and my USB-HDD connects to
> > the front ports. I have no problems stopping the drive before disconnecting
> > so your solution appears to be either machine or board specific.
> >
> > "Kenny" <me@privacy.net> wrote in message
> > news:OYUoa1csEHA.3508@TK2MSFTNGP14.phx.gbl...
> > > Have solved the problem. PC has 6 USB ports, 4 at back and 2 at front. I
> > > had been using one of the front ports and decided to try it at the back.
> > > Safe Removal option now works. I don't know why it works, the 2 front
> > > USB's
> > > are connected via header pins on m/b whilst the back USB's are integral to
> > > the m/b.
> > >
> > > --
> > >
> > > Kenny
> > >
> > >
> > > "Colin Barnhorst" <colinbarharst@msn.com> wrote in message
> > > news:OAybCLXsEHA.3200@TK2MSFTNGP09.phx.gbl...
> > >> If it behaves this way when attached to another computer, it might be a
> > >> defect in the hard drive controler or a cable or connection inside the
> > >> enclosure. Have you gone to the manufacturer's website for diagnostic
> > >> and
> > >> support options?
> > >>
> > >> "Kenny" <me@privacy.net> wrote in message
> > >> news:ev5ZGGQsEHA.3076@TK2MSFTNGP09.phx.gbl...
> > >> > Have added an IcyBox external HDD enclosure with a 160GB Maxtor drive
> > >> > in
> > >> > it.
> > >> > Works OK but when I try to stop it get the message.
> > >> >
> > >> > "Problem ejecting USB mass storage device.
> > >> > The device 'Generic volume' cannot be stopped right now. Try stopping
> > > the
> > >> > device again later."
> > >> >
> > >> > No problem with other external USB devices.
> > >> > Doesn't work even after fresh reboot. I sometimes see the HDD activity
> > >> > light
> > >> > on even though I'm not using the HDD. Maybe related is the fact that
> > >> > occasionally PC sticks at "Shutting down Windows" and I have to use the
> > >> > power switch. This was happening before adding the new HDD.
> > >> > Using XP Pro with SP1, updated chipset drivers and recent BIOS flash on
> > >> > Asus
> > >> > A7N8X m/b with Athlon XP 2500 & 512MB RAM.
> > >> >
> > >> > --
> > >> >
> > >> > Kenny
> > >> >
> > >> >
> > >> >
> > >>
> > >>
> > >
> > >
> >
> >
> >
 
G

Guest

Guest
Archived from groups: microsoft.public.windowsxp.basics (More info?)

Sorry to keep posting in separate messages...

It seems, it wasn't the change in USB ports, it was just the
unplugging/pluggin in. If I turn off my computer without "safely removing"
my HDD first, when I turn it on again, I'll get the error message.