[SOLVED] External HDD disconnecting

Rui Neves

Distinguished
Sep 20, 2014
1,100
19
19,315
18
Today I was connecting an hdd that is on a generic usb 3.0 case on the pc case usb 3.0 port and it didin´t connected the first time , tried again and then it connected but after a while working on hdd it disconnects and disconnects all other usb devices on pc either even the usb devices connected to the motherboard.

After this happened I changed the HDD to one of usb 3.0 on the motherboard and this time seems to be working fine for some hours already .



I connected a pen drive to the case usb 3.0 just to test if would happen the same that happened to the HDD and the pen drive works fine there , no issues at all!



Can I have some issue on the pc case USB or the USB could be not enough to handle the HDD power delivery ??
 

Darkbreeze

Retired Mod
Must be a problem with the case. Either the wiring or the integrated port. I'd suggest maybe, since it works fine on the back ports, try a hub connected to the back port. Gives you more ports and in general will be a bit more convenient than trying to plug into the back. Given the model of case and brand, not terribly surprising really.
 

Darkbreeze

Retired Mod
If you have something else plugged into the USB header on the case that is sharing the same internal USB header off the motherboard, and that device is active, then it might drop whatever is connected to the other header, either altogether or intermittently. If there is something else plugged into a shared bus on the front panel, try unplugging that device or dongle (And just plug IT in to the back panel) and then see if the external HDD now works on the front panel ports or not. If not, then maybe a problem (Not terribly uncommon) with the case circuitry, mini board, wiring, etc. or could be an issue with the motherboard internal header but I see a lot more problems with case mini board, wiring or ports than I do on boards. Which is not to say it can't just as well be the board, because it certainly can. It's just not AS common in THIS type of case.

What are your FULL hardware specifications?
 
Reactions: Rui Neves

Rui Neves

Distinguished
Sep 20, 2014
1,100
19
19,315
18
no only had that external HDD connected to the case USB´s , the case have 1 USB3.0 and one USB 2.0 and I was using only the USB 3.0 at the time , all other USB´s were plugged on motherboard USB´s.
that External HDD seems to work fine on Motheboard 3.0 USb´s , and my pen drive seems to work fine on the USB 3.0 on the case but the external HDD not .

My SPECS :
Case NOX Coolbay SX Blue
AOC monitor with 21" and freesync , 75hz
Gigabyte b450 gaming X
AMD Ryzen 5 3600
Kingston HyperX FURY DDR4 (with RGB) at 3200mhz with XMP profile 1 enabled
MSI RX 6600XT 8gb
Bitfenix formula gold 550w
3 hdd´s from WD ,(1 wd green , 1wd black ,1 wd blue)
1 ssd ( kingston a400 120gb)
 

Darkbreeze

Retired Mod
Must be a problem with the case. Either the wiring or the integrated port. I'd suggest maybe, since it works fine on the back ports, try a hub connected to the back port. Gives you more ports and in general will be a bit more convenient than trying to plug into the back. Given the model of case and brand, not terribly surprising really.
 

Rui Neves

Distinguished
Sep 20, 2014
1,100
19
19,315
18
Must be a problem with the case. Either the wiring or the integrated port. I'd suggest maybe, since it works fine on the back ports, try a hub connected to the back port. Gives you more ports and in general will be a bit more convenient than trying to plug into the back. Given the model of case and brand, not terribly surprising really.
Humm yeah you should be right , it's not hard to me to connect usb's on the Motherboard usb's but in this case it,'s just a little easier to have the external hdd sitting on the top of the case instead of my desk , luckly the desk is very close to the back of the computer :p , so not a big issue anyway .

But anyway it's not a bit odd that pen drives work fine on the case usb and not the HDD ?
 
Last edited:

ASK THE COMMUNITY