[SOLVED] External HDD keeps disconnecting while gaming / intensive CPU load ???

Ryflick

Reputable
Jun 23, 2019
26
1
4,535
0
Hey guys, I would like to know what causing my External Hard Drive keeps disconnecting while I'm opening some heavy apps like Unigine Heaven benchmark, GTA V, or any kind of games?

My specs are :
AMD Ryzen 5 4650G with Radeon Vega 7 Graphics
Motherboard MSI B450M-A PRO MAX
Netac Technology DDR4 RAM 3200MHz CL16 2x8GB
SSD ADATA SU650 480GB
HDD Seagate 7200RPM 1TB

The external Hard Drive is Toshiba 1TB

Everytime I tried to open External HDD directory while I'm gaming or either or doing any heavy load stuff it keeps disconnecting and re-connecting multiple times, is it caused by after I overclocked my APU?
I already did reset the BIOS configurations to default (stock speed and voltages) through CMOS reset, but it doesn't help.

Did I do something wrong here? What things should I do to fix this?
Apologies if my English is bad, I'm not a native speaker.
 

Ralston18

Titan
Moderator
That old PSU is a likely suspect...

Here are three links to help explain:

Best Power Supplies of 2022 - Top PSUs for Gaming PCs | Tom's Hardware (tomshardware.com)

8 Technical Specifications of PSU Explained - The Power Supply of PC - BinaryTides

https://www.lifewire.com/how-to-manually-test-a-power-supply-with-a-multimeter-2626158

Not that you should immediately go out and buy a new PSU or go about testing the existing old PSU.

Objective being to simply gain a bit more knowledge about PSUs and get a sense of what all may be or could be happening.
 

Ralston18

Titan
Moderator
PSU: make, model, wattage, age, condition (original, new, refurbished, used)?

History of heavy use for gaming, video editing, or bit-mining?

My thought is that the PSU may be starting to falter and fail. Thus can no longer keep up with system power demands.
 

Ryflick

Reputable
Jun 23, 2019
26
1
4,535
0
PSU: make, model, wattage, age, condition (original, new, refurbished, used)?

History of heavy use for gaming, video editing, or bit-mining?

My thought is that the PSU may be starting to falter and fail. Thus can no longer keep up with system power demands.
I'm currently borrowing the PSU from my uncle's PC. It's OEM from built-up PC.
Brand = Power Up
Model & Wattage = 500W
Age = I don't know, probably 4-5 years? It's kinda old, my uncle rarely use the PC so I borrow it for a moment until I buy my own personal PSU next week
Condition = Used
 

Ralston18

Titan
Moderator
That old PSU is a likely suspect...

Here are three links to help explain:

Best Power Supplies of 2022 - Top PSUs for Gaming PCs | Tom's Hardware (tomshardware.com)

8 Technical Specifications of PSU Explained - The Power Supply of PC - BinaryTides

https://www.lifewire.com/how-to-manually-test-a-power-supply-with-a-multimeter-2626158

Not that you should immediately go out and buy a new PSU or go about testing the existing old PSU.

Objective being to simply gain a bit more knowledge about PSUs and get a sense of what all may be or could be happening.
 

Ryflick

Reputable
Jun 23, 2019
26
1
4,535
0
That old PSU is a likely suspect...

Here are three links to help explain:

Best Power Supplies of 2022 - Top PSUs for Gaming PCs | Tom's Hardware (tomshardware.com)

8 Technical Specifications of PSU Explained - The Power Supply of PC - BinaryTides

https://www.lifewire.com/how-to-manually-test-a-power-supply-with-a-multimeter-2626158

Not that you should immediately go out and buy a new PSU or go about testing the existing old PSU.

Objective being to simply gain a bit more knowledge about PSUs and get a sense of what all may be or could be happening.
Thank you, I've been suspecting about the power supply lately and it seems the PSU is the culprit, I'll check your links and learn more about PSU and how to fix the current problems.
I'll update this post again later, thank you guys!
 
Jun 8, 2022
2
0
10
0
The important word I read in your post was overclock and APU in the same sentence. May I ask you to be honest about the temperatures it ran at maximum, voltages and whether you had disabled any of the safety features.

Failing USB is one of the first signs of a bad overclock, The way to check this is to identify if any of the USB ports run off the chipset as opposed to CPU. These will normally be a generation lower. I have checked your boards manual and the 4 3.1 ports on the back are direct to CPU and the Gen 2.0 run through the B450 chipset. To eradicate overclocking as the issue switch between these two ports and check to see the same behaviors on both. If one cannot sustain a connection its controller is failing, if both cannot the drive is failing.

I have to agree professionally with checking a PSU. This should always be a place of inspection when issues particularly during heavy load, however unless you have a spare one hanging around this isn't helpful.

So step one is to change the port to the slower one and see if the same behaviors exists. This should also eradicate the PSU temporarily as you are connecting to a more stable power source. The chipset gets it power regulated by the VRM's on the mainboard and is far less likely to fluctuate during heavy load. You are also not touching the current supplied to the CPU either, as if you are using the controller embedded within the CPU to power the drive this is extra current that has to pass through the CPU.
 

Ryflick

Reputable
Jun 23, 2019
26
1
4,535
0
The important word I read in your post was overclock and APU in the same sentence. May I ask you to be honest about the temperatures it ran at maximum, voltages and whether you had disabled any of the safety features.

Failing USB is one of the first signs of a bad overclock, The way to check this is to identify if any of the USB ports run off the chipset as opposed to CPU. These will normally be a generation lower. I have checked your boards manual and the 4 3.1 ports on the back are direct to CPU and the Gen 2.0 run through the B450 chipset. To eradicate overclocking as the issue switch between these two ports and check to see the same behaviors on both. If one cannot sustain a connection its controller is failing, if both cannot the drive is failing.

I have to agree professionally with checking a PSU. This should always be a place of inspection when issues particularly during heavy load, however unless you have a spare one hanging around this isn't helpful.

So step one is to change the port to the slower one and see if the same behaviors exists. This should also eradicate the PSU temporarily as you are connecting to a more stable power source. The chipset gets it power regulated by the VRM's on the mainboard and is far less likely to fluctuate during heavy load. You are also not touching the current supplied to the CPU either, as if you are using the controller embedded within the CPU to power the drive this is extra current that has to pass through the CPU.
Yes, before this I overclocked my APU to 2400MHz with 1.35Volt, that causing my External HDD goes nuts and I revert everything back to default / stock configuration.
About the temperature, I checked through HWiNFO64 and it ran at maximum of 65° C / 149°F. And also I remember the safety features is still on default setting / enabled.
I'll try to plug my External HDD through USB 2.0, if the problem still persist I'll update the problem again here.

From what I've check and test few days ago it really may be caused by the recent overclocking I've made and/or caused by the bad PSU.
My new PSU is arrived today and I haven't test my External HDD with it, I'll update my post here again later if it really caused by the bad PSU I used before.

Thank you so much for the help!
 
Last edited:

Ryflick

Reputable
Jun 23, 2019
26
1
4,535
0
Hi all, sorry for the very-very late update.
I've tested yesterday with a new PSU and turns out it works normally
Well it seems the old PSU isn't capable to supply the power for USB 3.0 I use, everything is normal until now, no USB failure.

Once again thank you all for the help!
 
Reactions: JohnBonhamsGhost

ASK THE COMMUNITY

TRENDING THREADS