External HDD Not Responding When Scanned For Virus

bijuu

Commendable
Jul 19, 2016
3
0
1,510
0
I have Hitachi Touro 1 TB and I borrowed that to my friend.
After he gave it back to me and I checked it, my HDD is not responding whenever I want to check/scan for virus(es). But I can open its folder normally when the HDD is not being scanned for virus.
It occurs only when I try to scan this HDD

any solution?
 
Hey there, bijuu.

This is pretty weird. Just to be on the safe side, backup your data (preferably to a drive without important info if you're worried about virus threats). After that go ahead and download the HDD manufacturer's diagnostic tool (or a 3rd party diagnostic tool if the manufacturer doesn't offer one) and run the tests, to see if anything unusual pops-up.
You could also give it a try with a different computer and a different USB cable.

Please let me know how everything goes.
Boogieman_WD
 

bijuu

Commendable
Jul 19, 2016
3
0
1,510
0


Currently, I'm running CHKDSK for this HDD, after that finishes I'll do your advice. Thank you for advice though. I'll let you know the result later.
 

bijuu

Commendable
Jul 19, 2016
3
0
1,510
0


Here's the result
http://imgur.com/HHOXHww

Am I using the right software? Can you explain what Read Element Failure means?
 
About the software, it does seem like it's the correct one since the HDD is Hitachi
Unfortunately it seems like the drive has failed one of the tests. I'd recommend that you get in touch with the vendor you got it from or the manufacturer, if the drive is still under warranty and try to RMA it.

And don't forget to backup your data if you haven't done so already.
 

ASK THE COMMUNITY

TRENDING THREADS