Question External HDD Plugged into SATA shows uninitialized

Apr 4, 2021
1
0
10
0
I checked my Seagate external drive, or tried to, but it just wouldn't open up in Windows Explorer. (It had been plugged into the PC's USB for months, but I had not bothered to access it in this period...previously it had been working fine)

Since I intended to plug it into the computer itself instead of hogging the USB anyway, I opened up the shell and found two Seagate/Samsung HDDs inside. I tried connecting each of these to my PC via SATA, but they didn't work - they wouldn't show up in Windows Explorer. When I run the Windows Partition Manager, I do see the drive, with a 33% of the drive showing as healthy and remaining as unallocated. I reckon I could merge the two partitions and initialize the drive(s), but that would mean losing the data.

Any suggestions as to how I could retrieve the data I have on these drives?
 
Seagate's external enclosures are configured with a sector size of 4096 bytes. When you remove a drive from such an enclosure, you expose its native 512e sector size and render the data inaccessible. Sector 0 is still in the same place, so your OS can see the partition table, but every other sector is displaced by a factor of 8, so the boot sectors are now in the wrong place.

You can still recover your data with DMDE (US$20). However, I suspect that your drives may have physical problems. To this end I would examine the SMART reports with a tool such as CrystalDiskInfo. Look for reallocated, pending or uncorrectable sectors. If the drives do in fact have physical problems, then it would be best to clone them with a tool that understands how to deal with bad sectors (HddSuperclone or ddrescue).

The other problem is that the 2 drives may have been RAID-ed. In a RAID 1, each drive would be a mirror of the other, so you have two chances to recover your data. Otherwise, if it's a RAID 0, then both drives will need to be working. A JBOD may allow a partial recovery if one drive is bad.
 

ASK THE COMMUNITY

TRENDING THREADS