Question External NTFS HDD not recognized by Windows 10 but Linux.

Nov 11, 2020
1
0
10
0
Hello everyone,
I'm facing an extremely weird issue. My external HDD enclosure (Orico 2520U3), with a WD5000LPCX attached in it cannot be recognized on my laptop only when I boot Windows 10. If I try to do anything to access the disk, like opening diskmgmt, diskpart, or running any hard disk manipulating tool (including 3rd-party ones), the system will halt. If I plug the disk in before I booted Windows, then the OS cannot boot (it keeps spinning over and over). Different USB ports were tried.

The other Arch Linux installation on my laptop can recognize and browse the disk flawlessly. It only contains one single NTFS partition, which was originally created in Windows 10 on another machine. I tried to delete the whole disk using cgdisk in Linux, then boot to Windows 10 again. The disk was recognized as "Unallocated". Then I tried to use diskmgmt to create a new partition. Unfortunately, the process halted in the middle. Using any third-party tool would result in the same thing. In other words, as soon as a partition appears on the disk, the system will halt.

I tried to plug the disk to some other Windows 10 PCs, and it was recognized just fine. I also tried to borrow my friend's HDD box and hooked it up to my machine (running Windows 10), and it unexpectedly worked flawlessly (??).

The machine (ThinkPad T14 AMD R5-4650U) originally came with Windows 10 1909. I reinstalled 1909 once, then updated to 2009. 3 mentioned installations cannot recognize my external HDD, only on Windows, and only on my machine. I cannot really understand what is going on with my HDD and Windows 10.

Apart from buying a new HDD box, what could I do to tackle with this issue now? Thank you.
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS