Question External SSD stops working on TV

Jul 31, 2019
3
0
10
0
Hello, I have Samsung T5 250gb external SSD and recently bought SONY XF9005 TV. I was watching a 4k HDR video of SSD and it froze up, after couple of minutes it said file couldn't be played. TV did recognize that SSD is pluged in, but it didin't read anything in it. I tryed all 3 USB ports, same thing happened after 15-20 min of playtime. Only thing that helped was unpluging TV from power for a minute. The SSD works fine on my other TV and on PC. Could the video file itself be a problem? It played 4k HDR videos before and it was fine, only difference was a file size and bitrate, this particular file was about 60gb and has V_MPEGH/ISO/HEVC HDR Video, 3840x2160 (16:9), 23.976 fps, 65.9 Mbps, videos before was around 20-30 Mbps
 
Aug 4, 2019
3
0
10
0
Hello, I have Samsung T5 250gb external SSD and recently bought SONY XF9005 TV. I was watching a 4k HDR video of SSD and it froze up, after couple of minutes it said file couldn't be played. TV did recognize that SSD is pluged in, but it didin't read anything in it. I tryed all 3 USB ports, same thing happened after 15-20 min of playtime. Only thing that helped was unpluging TV from power for a minute. The SSD works fine on my other TV and on PC. Could the video file itself be a problem? It played 4k HDR videos before and it was fine, only difference was a file size and bitrate, this particular file was about 60gb and has V_MPEGH/ISO/HEVC HDR Video, 3840x2160 (16:9), 23.976 fps, 65.9 Mbps, videos before was around 20-30 Mbps

Hello Mariusito. I have the same tv.

I had the same problem as well.The problem its not because of the type of the disk. From the moment the tv recognizes the disk and from the moment you play even 1ms of video the disk is not the problem. The culprit is not the mkv video either. The source is fine. We always blame the source lol


Few days ago I was experimenting with 4k content from an external Hard drive.

As I was watching the movie about 1 hour afterward, the video stopped. It wasn’t reloading, and also it wasn’t loading nothing else inside the disk.

I tried different solutions nothing worked for me except resetting the tv to factory defaults lol..Then the disk begun to work again. What a bs.

I tried to investigate a bit more, and I realized that culprits are 2 things:

  1. The pre-installed software Video application (red icon) inside SONY.
  2. The first 2 USB (side ports) (USB 2.0 port:500mA MAX, 800mA MAX)
Yesterday I managed to find (hopefully a permanent) solution.

The thing that worked for me is this:

  1. Move your External Hard Disk to the 3d Port(USB3.1 Gen 1 port:900 mA MAX). Its located in the back. The one with the blue input. I guess that port gives higher data transfer rate especially when it comes to 4k content and it doesn’t freeze.
2. Forget the default Software Sonny application Video. From Google Play, download and Install KODI. Its much better, faster, and more customizable.

Now I play all my 4k content including pictures and other videos through Kodi and through USB 3.1 port. I never had problem so far, no freezes of the disk but I will keep updating.
 
Last edited:
Jul 31, 2019
3
0
10
0
Thank you for replay, I think the problem was default Sony player, i downloaded VLC player form store and it seems to work fine for now.
 

ASK THE COMMUNITY

TRENDING THREADS