Question EZ Debug CPU light [SOLVED]

Jan 16, 2021
5
0
10
0
Hey. I've had this ongoing problem with my computer wich I cant seems to fix. The CPU light on the motherboard lights up, and the PC wont post. No signal in monitor.

My specs are:
Motherboard: MSI MAG B550 TOMAHAWK
CPU: AMD Ryzen 7 3700x
RAM: Corsair Vengeance LPX DDR4 3200MHz 16GB
GPU: ASUS GeForce RTX 2070 SUPER ROG Strix Advanced
PSU: Corsair RM650i, 650W PSU

I have tried:
  • Reseating the CPU.
  • Checking for no bent pins in the cpu and cpu socket.
  • Resetting the CMOS
  • Changing DIMM slots with both RAM, evern tried with only 1 of each in each DIMM slot.
  • Quadruple checked the 8 pin CPU connector and the 24 pin ATX.
  • Tried my CPU in another mother board (the RAM led lights up LOL)
  • Tried with another PSU
Any other suggestions before I throw the damn thing out the 4th floor window? :)

Thanks in advance!
 
Last edited:
Jan 16, 2021
5
0
10
0
the light led up in the other board but does not pass cpu boot part means you cpu is defect so boot process could no go on .
When I tried it on my ASUS ROG Strix B450-F GAMING motherboard it was the DRAM led that was lighting up. Could that still mean the CPU is defect?
 
Jan 16, 2021
5
0
10
0
so it pass the cpu test and lock on ram i would use only 1 ram module in the second system to see if it pass all boot process before that i would reset bios on the asus board .
I will try to contact the store and see if they can find any problems with the CPU. I still got warranty on it.
I will keep you updated. Thanks for the info :)

- Tommy
 
Jan 16, 2021
5
0
10
0
Random update:
I tried to put my CPU in my ASUS ROG Strix B450-F GAMING motherboard and now the led indicators goes from CPU -> DRAM -> VGA then restarts back to CPU. This is an endless restart. What is going on haha
 
Jan 16, 2021
5
0
10
0
you have a gpu with the asus board and monitor plug to it also it seams like he does not find any drive so boot process could no go on .
You were right, it was a defect CPU. I replaced it with a Ryzen 5 3700 and the system is running flawlessly. Even with both ram!
Thank you for your help!

- Tommy
 

ASK THE COMMUNITY

TRENDING THREADS