Question EZ Debug CPU White LED light on and no display ?

Jun 11, 2022
7
0
10
0
Hi all,

On boot up of my PC, I found there was no display or peripherals working and the “EZ Debug” light was on on the Motherboard. The CPU LED is lit white, and I’ve never had this issue before. The fans are working and my RAM is RGB but they are not running the programmed RGB sequence.

PC Specs
CPU: Intel i5-9600k
GPU: MSI GTX 1660 Super Ventus OC
Motherboard: MSI Z390-A Pro
RAM: Crucial Ballistix RGB DDR4-3200
SSD: Samsung 970 EVO Plus 500gb NVME M.2
HDD: Seagate Barracuda 2TB
Cooler: Deep Cool Neptwin (white)
PSU: Corsair TX-M 650w 80 Plus Gold
Mic/Headphones: Logitech G Pro Gaming Headset with Blue VO!CE Mic
Case: Fractal Design Meshify C (white)
Monitor: DELL P2419H


I am not sure what to troubleshoot, any advice is welcome. Thanks in advanced.
 

Aeacus

Champion
Ambassador
I am not sure what to troubleshoot, any advice is welcome.
You can start by doing this checklist,
link: https://forums.tomshardware.com/threads/no-post-system-wont-boot-and-no-video-output-troubleshooting-checklist.1285536/

But with the limited info you gave us, with 0 troubleshooting thus far, any of the following, or all of them are dead: CPU, RAM, MoBo, GPU.

You can rule out GPU if you pull the GPU from your PC and hook monitor to your MoBo. If you still can't get image, one of the three, or all of them are dead: CPU, RAM, MoBo.

Debug LED points the issue towards CPU. Could be bent CPU socket pins. Or it is dead MoBo. Most of the times, it's faulty MoBo.
To know for sure, you need 2nd, compatible PC, where to test out each component individually. Or haul your PC to PC repair shop and let them figure it out, while paying for repairs.

I suggest doing the checklist 1st, since it includes several helpful steps. E.g your issue could be easily solved if the issue is with loose power cable (+12V EPS) or similar.
 
Last edited:
Jun 11, 2022
7
0
10
0
Update, I have tried to do the steps as per @Aeacus and the last thing to check is the CMOS.
Still no boot up from the previous steps as outlined, ie boot with one RAM, check connecting cables, and more.
I will update once I have tried CMOS method. Thanks.
 
Jun 11, 2022
7
0
10
0
Update, CMOS done but still having the same issue. No display and CPU light still lit on mobo’s ez debug. I will reseat and check the CPU next.
 

geofelt

Titan
Hardware failures after a while are uncommon, but they do happen.
Intel cpu failures are very rare.
Most of the time, a bent socket pin results in some sort of storage issue, not a complete boot failure.
A failed motherboard is more common.
My first suggestion would be to check your power connections.
Your video shows that you are using white custom power leads.
Pretty, yes, but I would try using the power leads that came with the psu.
If no joy, try using a known good replacement psu.
If you ultimately conclude that the motherboard is at fault, I would consider
replacing both the motherboard and cpu with a 12tg gen replacement.
 

Aeacus

Champion
Ambassador
Did you do step #22 in the checklist as well?

Once checklist is done and there's still no change, i too suggest trying with 2nd, known to work, good quality PSU. And if even 2nd PSU doesn't help, then i'd look towards new MoBo.

Either another Z390 chipset (given that your CPU survived, which is very likely), or 11th or 12th gen CPU with compatible MoBo. Oh, you need to be careful with MoBo selection if you go with Intel 12th gen CPU, since some MoBos support only the newest (and expensive) DDR5 RAM. While there are those out there that also support DDR4 RAM (so, that you don't have to replace your RAM either.
 
Jun 11, 2022
7
0
10
0
Update: PC boots up but now shows
WHEA_UNCORRECTABLE_ERROR

It booted up for a min after I exited out of bios- logged in and got my homepage, then BSOD comes up with that error.

On restart-
• Sometimes I get the same primary fault I started with which is is the CPU white LED light is on the EZDebug, no display, no peripherals, etc.

• Other times I get a quick LED light on VGA EZDebug on mobo and then to Windows log in page. Sometimes I get to log in to homepage and within seconds BSOD with WHEA_UNCORRECTABLE_ERROR code.

• Another time I get blue screen RECOVERY page with a notification saying “It looks like Windows hasn’t loaded correctly” with the option of “see Advanced repair options” or “Restart my PC”
-on restarting PC it will give me one of the above mentioned boot ups

Looks like I’m stuck on a reboot loop. Any ideas for next step?
 

Aeacus

Champion
Ambassador
Since you've exhausted the checklist i linked, now, you're only left with component testing.

Component testing is only viable, when you can get spare parts cheaper, than going with new CPU-MoBo combo.

For as little as 200 bucks, you can go with new CPU (i5-11400) and MoBo (B560);

PCPartPicker Part List

CPU: Intel Core i5-11400 2.6 GHz 6-Core Processor ($167.99 @ B&H)
Motherboard: Gigabyte B560M DS3H AC Micro ATX LGA1200 Motherboard ($59.99 @ Newegg)
Total: $227.98

Prices include shipping, taxes, and discounts when available
Generated by PCPartPicker 2022-06-29 10:05 EDT-0400


i5-11400 is equal to the performance of your i5-9600K, with small difference of it having 12 threads, while your i5 has only 6 threads. Now, if you're willing to spend more money, you can get better CPU as well, but that would be the bare minimum, in terms of new CPU-MoBo to get.

And with only 200 bucks, i doubt that you could find another Z390 chipset MoBo, especially since your MoBo might not even be the issue. Could be your i5 too.
 

ASK THE COMMUNITY

TRENDING THREADS