Question Ez-Debug stops after CPU?

May 17, 2021
30
0
30
0
CPU: R7 2700x, R5 1400, A6 9500E
GPU: Sapphire R9 290x
RAM: 2x TG 2666, 2X G.Skill 3200
MOBO: B350M Mortar Arctic

Symptoms: CPU light turns on, turns off. No other debug lights come on. Does not complete POST.

What I've done:
-CMOS reset
-Ram in every config
-CPU swaps (A6 works, Ryzen series do not)
-Update BIOS
-Update CPU drivers
-MSI unofficial tool (failed)
-Check standoffs and all connections.

Link to previous thread: https://forums.tomshardware.com/threads/b350m-and-ryzen-7-2700x-wont-post-even-after-bios-update.3704008/?view=date

So I've gotten a used GPU, known good condition. I'm pretty much at a loss for now, I've tried everything I could think of, and was given plenty of guidance in my last thread. Nothing has worked so far.
When using the A6 BIOS recognizes the R9, defaults to it, and I get signal from the card's HDMI port. Changing nothing but the CPU the computer fails to POST, or at least freezes mid POST.
I'm taking the computer to a specialist tomorrow for diagnosis, and I'll update with what is found then as I hate problem threads that just stop with no description of the solution. In the mean time I'm wondering if anyone has any ideas as to what the problem could be? I've tried swapping just about everything on the computer except the motherboard. Tbh there's a good chance that's it at this point, but I don't know how it can be hardware if everything works absolutely fine with the A6 GPU?
Thank you all in advance,
Mark
 
May 17, 2021
30
0
30
0
Wednesday update:
Verdict from specialist is bad CPU. I took said CPU to a repair shop who is pretty friendly with me, put it in one of their computers running an R3, and it booted with no problems. So I don't know what's going on now, and after telling the specialist they don't either.
Tomorrow I'm returning to the friendly repair shop and they're going to let me swap that R3 into my computer to see if it works. If it does, bad CPU with reliability issues. If it doesn't, bad MOBO. Will update then.
 
May 17, 2021
30
0
30
0
So the issue ended up being the motherboard. All my CPUs work on this board, though it does seem like my old GPU is fried. Just didn't want to leave a thread unsolved.
 

ASK THE COMMUNITY