Question F-panel H510 problems

Aug 14, 2020
6
0
10
0
Case - NZXT H510
Motherboard - ROG Strix B450-F Gaming
GPU - MSI RX580
CPU - Ryzen 3 3200G
RAM - Corsair Vengeance RGB 2x8GB 3200Mhz
PSU - Aerocool Integrator 600W 80+ Bronze

I'm in bed after a day of fiddling with a new rig, so I'm not in a position to do any more tinkering until tomorrow. I thought I'd ask in case anyone has any ideas anyway. If you have something you need me to try, it won't happen right now.


The problem I have is the power button won't work. I jumped the pins and the rig works fine. It's the connection to the panel. I've checked the connectors are plugged in properly - as far as I can tell, they are. My wire has an Intel header, and comes with an adapter for non-intel boards (which is what I'm using) - I've also tried to check said adapter, and as far as I can tell, it's connected properly. After having my pc on for a while and sorting stuff out, I shut it down. I attempted to fix the fpanel again, and tried another boot. The connectors still didn't work, so I took them out and jumped it. System still fine, button still doesn't.
 
Last edited by a moderator:

popatim

Titan
Moderator
Assuming you are jumpering the Front panel (FP) pwr pins to get the system running then the Case or the adapter has an issue. Does the Cases FP wiring have different colors for the individual wires? Is so them we can see which colors are for the Pwr sw and make sure they line up with the adapters pwr plug wires.
Otherwise it will take some troubleshooting with a multimeter to test the switch and trace the wiring down to the plugs.
 

ASK THE COMMUNITY