Question Failed BIOS update, followed by a series of problems ?

Nov 23, 2020
1
0
10
0
My specs first:
Intel I5-8600k CPU
Xfx Rx 580 GPU
1200w corsair PSU
AORUS Z390 LGA 1151 Motherboard
16GB Corsair vengeance RAM.
HDD x 2

So I tried updating my bios because during gaming i would randomly lose signal to my monitor and the gpu fans would go to 100%. That's a whole separate problem though. I tried to update the bios using @bios from the gigabyte aorus support site. Right after it started i got a message saying it failed and windows was collecting a report. Computer turns off.

When i go to turn it back on, it starts up, then shuts down, starts up, shuts down, then starts up for a minute but i recieve no signal or anything, then shuts down. I pulled out the GPU, disconnected the RAM, removed the cmos battery, shorted the cmos pins for 5 seconds, re installed the battery, ram, but not the gpu and plugged my HDMI straight into the MB. Once i plug it back in, i get a very short LED flash from the Motherboard itself, but it wont turn on at all. No fans turning on, nothing. Please help i really would prefer not dropping another 260$ on a motherboard.
 

ASK THE COMMUNITY

TRENDING THREADS