Failed to Initialize Renderer (Fallout 3)

Oct 20, 2015
14
0
4,510
0
So I played Fallout 3 for a while, and everything ran beautifully. No problems would ever occur. Then one day, I went to play and when I pressed play on the launcher and it a a tad popped up and said : Failed to initialize renderer. I messed around with all of my setting in the launcher, like changing my resolution and lowering my settings, but nothing seems to work. I went into my Nvidia control panel and went to manage 3d settinggs and changed fallout to use my intel graphics card to see if that would work. When I launched my game, it would work like normally and get me into the homescreen of the game, but then when I would press play and load a new game, the game would crash, (Which isn't that much of a surprise because I'm pretty sure my intel graphics cant run fallout.) So after that, I went back into my Nvidia control panel and changed Fallout back to my High Performance Nvidia Processor and launched Fallout, and same problem, failed to Initialize Renderer. With Fallout 4 around the corner, I really want to play some FO3 so if anyone has a fix for this it would be much appreciated.

Specs:
Intel Core i7 4710hq @2.5GHz
My two graphics cards are Nvidia GeForce 860m 2 GB of VRAM and Intel HD Graphics 4600 2GB of VRAM
(I always use my Nvidia, never once have used my intel graphics for anything)
16 GB of Ram
Windows 8 64 Bit
 
Look for the falloutprefs.ini file in the fallout 3 game folder.
or fallout_default.ini
Right click on the ini file.

select wordpad as the program to use with the file to edit it
Edit the settings.

Then save it before you close the window.

You can change everything to do with the graphics settings of the game to what graphics card the game must run with.
 

jaguarskx

Titan
Moderator
Try to delete the FalloutPref.ini and allow Fallout 3 to create a new one by using whatever graphic settings that you want.

Try updating your graphic drivers. If it is the latest version, then uninstall them in Windows Safe Mode, then re-install them.

If that does not work, then try downloading the following "Windows 7 & 8 fix". It is basically a d9s3.dll that you place in your Fallout 3 directory. It was originally designed for Oblivion under the "Oldblivion" project to allow DirectX 8 GPUs to run Oblivion. It also allows Intel HD graphics cores to run Oblivion and Fallout 3.

http://www.nexusmods.com/fallout3/mods/20371/?tab=1&navtag=http%3A%2F%2Fwww.nexusmods.com%2Ffallout3%2Fajax%2Fmoddescription%2F%3Fid%3D20371%26preview%3D&pUp=1

Perhaps it will bypass whatever is causing the error you are getting so that you can play FO3 with your GTX 860m again.
 

Similar threads