Fan error after changing CPU

RC80

Reputable
Jun 19, 2015
16
0
4,510
0
I'm getting an alert when I boot up that says rear fan failure on my dell optiplex 745, but the fan is working. The error started straight away after I put a new CPU into my pc. The new CPU is more energy efficient so it needs less cooling than the previous chip. The fan is way quieter now, but I can hear it and is definitely working. I checked wires and everything else and its connected perfectly. Do you think that maybe the motherboard has a minimum speed set for the fan for the previous chip, and my new one is not causing the fan to get to this minimum speed because its doesn't need it and thats whats causing the error?

Previous CPU: Intel Pentium D 820
New CPU: Core 2 Duo E6600
 

Deuce65

Honorable
Oct 16, 2013
1,467
0
11,960
268
Wait, I just saw what your old CPU was. So that model had several CPU choices available. The lesser model (single core) did not come with a rear fan so the bios\preboot diagnostic skips that check. The dual core model did come with a rear fan. It is probably getting confused at this point, thinking the rear fan should be installed, when there never was one.
 

RC80

Reputable
Jun 19, 2015
16
0
4,510
0
There is nothing in power management to disable in relation to this. I only see an event log in maintenance, I think, that says the fan is out of range. I cleared the log but to no avail.
 

koffeeshop77

Reputable
Jun 9, 2015
1,160
0
5,660
111
then you need to go through all bios options and find the setting, .. did you plug ther fan back in the same plug as the old one was? you may just have to plug it in the same plug on the mother board and may fix your prblem but somthing is definltly monitory you fans and you can usaully turm it off somewhere in the bios.
 

Deuce65

Honorable
Oct 16, 2013
1,467
0
11,960
268
When you replaced the CPU, did you use the same HSF that came with the machine, or a new HSF? The Dell bios (and the preboot diagnostics) expect everything to be factory originals and if they are not, it will fail that portion.

That machine is a bit old so my memory may be off, but I *think* it should be under system setup > post behavior > keyboard errors and you turn to do not report. It will still tell you on booting that the fan is broken but it will then attempt to boot anyway without any keyboard pressing from you.
 

RC80

Reputable
Jun 19, 2015
16
0
4,510
0
Nope, there is absolutely nothing there to turn off in relation to this. I turned off SERR messages and keyboards messages to see what would happen, but it didn't work unsurprisingly. I never removed the fan when I was changing the CPU, I only needed to remove the heat sink.
 

RC80

Reputable
Jun 19, 2015
16
0
4,510
0


I missed this post when posted the last one. I will try this now to see will it go ahead and boot.

 

Deuce65

Honorable
Oct 16, 2013
1,467
0
11,960
268
Wait, I just saw what your old CPU was. So that model had several CPU choices available. The lesser model (single core) did not come with a rear fan so the bios\preboot diagnostic skips that check. The dual core model did come with a rear fan. It is probably getting confused at this point, thinking the rear fan should be installed, when there never was one.
 

RC80

Reputable
Jun 19, 2015
16
0
4,510
0


Unfortunately that didn't work. It didn't try to boot anyway. The HSF are the same ones. I only changed the CPU. Its getting late so I'm going to leave this till tomorrow. Thanks for everyones help.
 

RC80

Reputable
Jun 19, 2015
16
0
4,510
0


Ah, thats explains everything because yes there is no rear fan. I just thought that it was on about the front fan because the fan was quieter it wasn't reaching a minimum speed to work at and the motherboard was reading it as broken. So, I probably can't get rid of this error?

 

RC80

Reputable
Jun 19, 2015
16
0
4,510
0

bjsm

Distinguished
Jul 25, 2011
913
0
19,160
80
You should be fine, just keep your money and ignore the warning. Thats what i would do. If you really want to fix it try to find the same connector and plug it in or just buy one from ebay like u linked
 

RC80

Reputable
Jun 19, 2015
16
0
4,510
0
Maybe I could do with it. My HDD is 56 degrees at the moment according to speccy which is higher than it should be I think.
 

Deuce65

Honorable
Oct 16, 2013
1,467
0
11,960
268
The HDD fan is the correct one to get. It attaches to the hard drive caddy but it is NOT a fan for the hard drive. It is for cooling the memory controller. The conroe chips as you can probably see run a lot cooler, so much so that the CPU fan doesn't kick in very high, very often. Dell felt that including a fan there for the memory controller would be a good idea. I would recommend getting it.
 

RC80

Reputable
Jun 19, 2015
16
0
4,510
0


Yeah, I'm going to get it. Its very cheap anyway. Thanks for the advice lads!

 

ASK THE COMMUNITY

TRENDING THREADS