Question Fans and lighting stay on after shutting down my PC ?

davidbozovic1

Reputable
Aug 29, 2017
11
0
4,510
0
Today I bought an m.2 ssd, installed it and after powering on I got a "cpu fan error". Went into BIOS and saw that it's not detecting my fan nor the m.2. I took out the m.2 and the PC works fine (with fan settings set to Ignore, because the fans do work). When I want to shut down my PC the fans and case lighting stays on forever. I disabled fast boot in Windows and BIOS. Have I perhaps short circuited something? I have plugged out the pc entirely and flipped the switch on PSU before installing the ssd. I'm not sure what to do. I contacted and reported to Kingston support regardless.

Specs: ryzen 5 2600, asus a320m-k prime, gt 1030, 2x4 gb 2133mhz ram (dual channel), hitachi 500gb hdd, kingston a2000 250gb m.2 ssd ( see above), 500W PSU that held this all together with no issues

If the damage has already been done can I minimize it somehow?
 

Colif

Win 10 Master
Moderator
I would check to see if there is a newer BIOS for motherboard than the one you are on.

its possible you need a new CMOS battery as bios may have forgotten settings.
when you start up, go into bios/save & exit screen and choose load optimized defaults.
 

davidbozovic1

Reputable
Aug 29, 2017
11
0
4,510
0
Update: I have installed the m.2 again , and it works, although it's not detected by BIOS, in some settings it is , and in other it isn't. Running windows 10 on it smoothly. PC still won't shut down though, with the power led staying on forever. Is it a mobo issue or a PSU issue? I contacted Asus and they told me to go to my dealer for diagnostics, but that's impossible since I bought it in another country.
 

ASK THE COMMUNITY

TRENDING THREADS